How to link your Toppy to a PC or Mac; networking your Toppy, Web-based EPG systems, DVD burning and file transfers

Moderators: Technical, Oz mods

Post Reply
bacoms
Regular contributor
Posts: 58
Joined: Thu Feb 23, 2006 3:08 pm

Toppy no longer accessible via Slug

Post by bacoms »

I haven't tried accessing my Toppy via local network for a few years now but used to do it all the time, certainly when running XP.

Tried again recently without success and wondered where I should start looking. I'm no expert at this and remember the long winded process I had to go through to set it all up before, so any help in avoiding having to start again would be appreciated.

Currently the Slug is listed as a connected static device under Wired Connections on my BT Hub and I can successfully ping its IP address but that's about it.

Using raw Telnet gives the error message 'Could not open connection to the host, on port 23: Connect failed'. Usiung Putty gave 'connection refused' message.

Trying to Browse to the IP address gives 'not reachable' message. I seem to remember Telnet had to be enabled/disabled using the browser.

Thinking back to when it all worked, it was probably pre Windows 10. Could this be the problem?

Any thoughts?
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; EPG2MEI v0.96; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PruneEPG 1.0; fsSave 1.1;
Sig generated by MyInfo on 2/5/16
?
Geoff Bacon
Frequent contributor
Posts: 4669
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

I was having trouble getting my slug to work on my main toppy - I assumed it had a psu problem. However, before throwing it out, it worked fine on my old XP system to my test toppy.

The cable from the router needs to go to the slug (you can't connect slug directly to pc)
The memory stick needs to be plugged into Disk2 on the slug
The toppy cable goes into Disk1

My slug was configured to 192.168.1.77 (yours might be different)

To open in browser use http://192.168.1.77/Management/telnet.cgi. You will need to log in (probably admin/admin, try root/uNSLUng if admin doesn't work)
The above probably just enables Telnet operations

If you are using TopManager to connect, you will probably have to create a connection that uses INDY communication (assuming ftp-topfield was started with -E).

That is all the help I can give.

If it is a one-off, might just be easier to move the pc and/or toppy so that they are co-located and then use USB as the connection method.

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
EMJB
Frequent contributor
Posts: 3645
Joined: Fri Jul 08, 2005 9:43 am
Location: Maldon Essex

Post by EMJB »

A recent major update to Windows 10 Pro (to build 1803 IIRC) which seems to badly affect some Delphi programs such as the MyStuff installer, but also affects communication with Linux devices such as Slugs and Pis. If you have installed this update (which may have an equivalent for other W10 versions) it COULD explain your problem.

Microsoft have acknowledged the existence of the Delphi-related problem, and I have spent many hours fighting the Linux-related problems with very limited success, so I have reverted to the previous build and everything worked agian with no problems.

EMJB
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
Post Reply