For technical discussions, work-arounds and fixes - not for general moans

Moderators: Technical, Oz mods

Post Reply
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi

I have a problem with my toppy, constantly rebooting.

Recent history AFAICR.
Over the past few months I have had numerous crashes - the toppy reboots and the message checking files appears. Then is fine until the next crash.

I tried to resolved this by first deleting the No of channels I had from over 100 to 50 or so.

I then deleted all out of date textsearches. Leaving less than 10, however one particular search had 25 or so instances set and kept that level going forward.

The other morning, the toppys display was showing REC, when I checked, the screen had frozen part way through the previous nights recording, when I restarted the toppy it just kept going through the reboot cycle.

I have rebooted without taps by holding down 0. Toppy was working. I could see recordings, but the epg data was absent and the headers for channels were filled with spurious characters.

A previous post indicated the EPG file may have been corrupted, so
I deleted the epg.mei file as suggested. On the understanding that this would be reconstructed by the toppy. After waiting several hours however, a new epg file was not reconstructed. (Should I have also deleted the other two files EPG.raw & EPG_diff.mei ? )


In order to ascertain if there was a broken TAP have taken TAPs individually out of autostart, and switched toppy off then on. This made no difference I was still getting constant reboots.

I then took all TAPs out of autostart, toppy worked same as with holding down 0.

I replaced ONLY the EPG2MEI TAP into autostart, the problem returned constant reboots !

I have found another thread with a similar problem, where Geoff Bacon was giving advice.

So I have opened Topmanager.
I have made the usb connection.
I cannot perform the next step however as the fscheck option is greyed out. I can only see the MyStuffExportOptions, the four MyInfo options and Extend.log Display/Delete options all others are greyed out.

So where do I go from here ?
1. Is it necessary remove the other two EPG files. EPg.raw and EPG_diff.mei in order for the EPG to be reconstructed.
2. Do I try empty settings OR factory reset ( as I can still get to the stock topfield menus)
3. Is the EPG2MEI TAP a necessity to construct the EPG. Or does the toppy do it a different way.
4. Can I load a new EPG file from elsewhere or does it have to be constructed and populated by the toppy itself over time.

Best regards
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

First, have all the capacitors on the PSU been replaced? If not, this is the likely cause of all your problems (switch it off to prevent further problems and/or loss of recordings; contact Andyfras for his repair service)

It is hard to tell what your configuration is (you don't have a forum signature), but I'm guessing that you are using MyStuff (otherwise you would probably not be using EPG2MEI).

Grayed out options in TopManager: I'm guessing that although you created the connection, you omitted the "Connection| Open" i.e. you are only seeing the options for things before TM connects to the toppy.
Note: The "Display | fscheck" option will only be enabled if you have run fsCheck.tap on the toppy and saved the log output to disk.

You could connect to the toppy and post your latest MyInfo (although it will be incomplete as you have moved taps out of Autostart) but my advice (assuming the psu needs repair) is
1) fix the psu
2) Run GCBMyStuffInstaller and select option 1 (to ensure everything is up-to-date)
3) Don't attempt anything else until you have got this far!

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Post by MacC »

Hi Geoff

Sorry I should have said in original post.

I have replaced the all 18 capacitors, but probably about 5 or 6 years ago.

I was intending to replace my HDD before this problem, so I had checked the voltages a couple of weeks ago. They were all within tolerance.

I had read somewhere the tuners may cause problems, so I checked the reg U20 and had got readings of 1.25v at the tab and 2.96v at the leg.

I had just received last week a new 80 wire IDE cable, I already had a PATA SATA convertor board and a 2TB Seagate Barracuda HDD both of which I had originally bought with a view of upgrading my very old PC, however that never happened.

I have closed Topmanager then restarted it, then used the connection open option, but it's just the same reduced options only available.

I'll check the pay voltages again, assuming they're OK you say I should I run GMBMyStuffInstaller, I'm not sure what this is, I have however downloaded the BuildOffLineMyStuffInstaller to my PC.
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

Voltages don't mean anything to me - I'm a software engineer,

The Display options in TM are only enabled if a corresponding file exists on the toppy.

Suggest you do a Connection|Browse (after opening); if that displays the ProgramFiles tree then the toppy has connected properly and the disk is visible to the PC.

On the toppy, use the remote:
1) Archive (I'm assuming MyStuff is not in Auto Start)
2) << (to view ProgramFiles, repeat if show MP3)
3) Scroll down to Utilities (assuming it exists) and press OK
4) Scroll down to fsCheck and press OK
5) Press Archive (or record?) to close fsCheck (this writes the file)
6) TM Display | fsCheck should now be enabled; select it
7) Right Click in bottom panel and "Copy to ClipBoard as Text"
8 ) Paste it into the fsCheck Reports thread (I want to see what the SMART characteristics say about the physical state of the disk).

Note: if Utilities and/or fsCheck don't exist, install it with TM Tools| Install Files

You can use BuildOffLineMyStuffInstaller if you want but it has been superseded by the program I linked to in my previous thread.

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
andyfras
Frequent contributor
Posts: 3486
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire
Contact:

Post by andyfras »

MacC wrote:.. so I checked the reg U20 and had got readings of 1.25v at the tab and 2.96v at the leg.
Those should read 1.5V and 3.3V, but before doing anything else, check the rest of the voltages, as I suspect your meter may need a new battery. The 3.3V rarely reads low.
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi Geoff

I have performed connection browse and can see the program folders and the contents in Utilities, but no fscheck. So I have downloaded, installed and run it.

I have now posted the report in the appropriate thread.

FYI
The files I have in Utilities folder are

ChannelOrganiser.tap 0kB (zerokB)
fastscangui.tap 64kB
FwLoad.tap 144kB
HDDinfo.tap 100kB
SerialTransfer.tap 177kB
SignalMonitor.tap 68kB
TapCommander.tap 217kB

Regards
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi Andy

The voltages were as follows:

PSU. Main Board

31.2v. 31.2v
24.5v. 24.4v
17.1v. 17.1v
0v. 0v
7.55v. 7.54v
0v. 0v
5.0v. 5.0v
0v 0v
3.27v. 3.26v
0v 0v
15.65v. 15.6v
0v. 0v

So all voltages seem within tolerance.

However the "3.3v" line is near enough identical at both connectors 3.27v cp 3.26v but drops to 2.96v at the leg of the regulator. ?
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

@MacC

zero bytes for a tap is not good! - especially as you will need it to retune the toppy (unless you do it with TopManager |PcControl| Channel Management).
Both these tuning methods rely on data files which will be provided by the GCBMyStuffInstaller

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
andyfras
Frequent contributor
Posts: 3486
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire
Contact:

Post by andyfras »

Sorry, your reading of the right hand leg is correct, it is supposed to be about 3V.

However, as the tab is reading 1.25V, U20 has failed. It should definitely be very close to 1.5V.

I can supply a replacement if you want to replace it yourself, or you can send your Toppy to me.
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi Andy

I'd appreciate it if you could supply the replacement regulator.

Regards Macc
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi Geoff

I have tried to install MyStuff using the GCBMyStuffInstaller and option 1.

However it has failed, message reads "Installation failed performing last displayed operation.

I have checked the programs files and only EPG2MEI v0.96 and PruneEPG 1.0 have been installed.

Could this have been because I had left the original EPG2MEI file in program file, or would that file just have been overwritten.

I have made a copy of the full installation report if it helps I can post it, just tell me the most appropriate place. I.e do you have a separate thread as per fsCheck reports ?

Would it help if I clear all program folders of my original TAPs & files or is it easier to perform a factory reset before trying another fresh install.

Regards Macc
ccs
Frequent contributor
Posts: 2689
Joined: Tue Oct 30, 2007 3:19 pm

Re: Locked in reboot cycle

Post by ccs »

MacC wrote: However it has failed, message reads "Installation failed performing last displayed operation.
This should tell you what failed.
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
MacC
Regular contributor
Posts: 76
Joined: Mon Sep 26, 2005 12:21 pm

Locked in reboot cycle

Post by MacC »

Hi

This is the last section of the installation report.

175: ########################
176: ### Main MyStuff tap
177: ########################
178:
179: FlagConditional: Flag_Copy_MyStuff(True) Do you want to copy MyStuff.tap?
181: CopyFile: MyStuff_FreshInstall.dat #:\ProgramFiles\Settings\MyStuff\
Installation Failed performing last displayed operation.

Regards Macc
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

There should be a file called "MyStuff Installer Log (Paste Into Forum).txt"
Just paste it into this thread.

The implication is that there was an error copying to the disk.I'm not sure what U20 does but perhaps you need to reinstall after it has been replaced ( here is a thread describing how dwright did it).

You shouldn't need to wipe any files or do a factory reset.
Suggest you switch it off until U20 fixed

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
andyfras
Frequent contributor
Posts: 3486
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire
Contact:

Post by andyfras »

U20 supplies power (1.5V) to the main processor.
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
Post Reply