For technical discussions, work-arounds and fixes - not for general moans

Moderators: Technical, Oz mods

Post Reply
Frequent contributor
Posts: 3495
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire

Xtrend ET8500 Stuck in Standby

Post by andyfras »

I recently fixed the above. The problem was capacitors in the external PSU. 2 x 1500uF @ 16V were significantly bulging. When I initially checked the voltage on the PSU plug, it showed 12V, but when it was plugged into the unit, it struggled to make 5V. All working again now.

The most difficult part was opening the PSU which was glued together. I patiently worked around the join with gentle squeezing using water-pump pliers. Then, once it started to open a gap, gentle leverage finished the job.

I had also opened up the Xtrend, and was very impressed with the build quality and ease of access.
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
Frequent contributor
Posts: 420
Joined: Wed Mar 29, 2006 1:25 am
Location: The Sunny Kingdom

Re: Xtrend ET8500 Stuck in Standby

Post by jimi »

Good job 8) I've used a similar technique but with a vice to crack open different sealed units.
I'm still surprised at the number of capacitor related faults on "modern" (2000 ? onwards) consumer electronics. Offshore a lot of the electronics I worked with were much older 70/80's stuff, capacitor problems were pretty rare, in rare even on newer equipment. The majority of offshore equipment was in use 24/7.
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+Pe
TAPs: PcControl B1.4; Extend v1.7; EPG2MEI v0.96; SecCache (UK) v0.4; EIT Sub (Game) v0.6; Font Manager 1.0d; MHEG On/Off A3; (MyInfo B5.6); PruneEPG 1.0; MyStuff 6.6;
Sig generated by TopManager/PcControl on 16/12/20
Post Reply