How to link your Toppy to a PC or Mac; networking your Toppy, Web-based EPG systems, DVD burning and file transfers

Moderators: Technical, Oz mods

Post Reply
CharlieBoy
Frequent contributor
Posts: 139
Joined: Sat Mar 04, 2006 3:39 pm

Post by CharlieBoy »

Is anyone other than me still using the Microsoft Legacy source? As of yesterday I'm getting data for the TV channels but nothing for any of the radio channels. Would be interested to know if it's just me or whether Microsoft Legacy are failing to supply any radio EPG data?

Thanks
Charlie
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -FmSy+UUu
TAPs: PcControl B1.4; MyInfo B5.6; EPG2MEI v0.96; MHEG On/Off A3; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; Deepletterbox 2.44; PruneEPG 1.0; MyStuff 6.6; (StartCh); (fsSave 1.1);
Sig generated by MyInfo on 14/4/18
?
TopTapper
Frequent contributor
Posts: 237
Joined: Sun Jan 29, 2006 4:18 pm

Post by TopTapper »

CharlieBoy wrote:Microsoft Legacy source? As of yesterday I'm getting data for the TV channels but nothing for any of the radio channels
I've just tried adding radio - 704 & 707; the channels seem to be picked up...

Code: Select all

... xmltv.xml : last output 19/01/2017 19:31
... mc2xml.chl: 1-6, 9-10, 14-15, 21, 24, 28, 30-32, 47, 704, 707
... mc2xml.ren: [file not found]

Loading ..... &#58; mc2xml &#40;c&#41; <mc2xml@gmail.com> &#40;v1.6&#41;
Reminder .... &#58; Unauthorized redistribution prohibited.
Reminder .... &#58; If this software is useful, please donate!
Reading ..... &#58; mc2xml.dat
Downloading . &#58; microsoft.com
Downloaded .. &#58; 724112 bytes in 3s
Source ...... &#58; BDS
Headend ..... &#58; 120020
Version ..... &#58; 2953735541
Start time .. &#58; 2017-01-20T00&#58;00&#58;00 UTC
End time .... &#58; 2017-02-03T23&#58;58&#58;00 UTC
Parsing ..... &#58; Freeview - Crystal Palace
Reading ..... &#58; mc2xml.chl
Writing ..... &#58; xmltv.xml
Writing ..... &#58; mc2xml.dat
Completed ... &#58; 4774007 bytes in 4s, 19 channels, 5737 programs scheduled.

... xmltv.xml &#58; has been updated

Code: Select all

	<channel id="I704.323.microsoft.com">
		<display-name>704 BBC Radio 4</display-name>
		<display-name>704</display-name>
		<display-name>BBC Radio 4</display-name>
	</channel>
	<channel id="I707.751644.microsoft.com">
		<display-name>707 BBC 6 Music</display-name>
		<display-name>707</display-name>
		<display-name>BBC 6 Music</display-name>
	</channel>
... but there's no radio data.

The TV data is very hit and miss; it'll deliver every day for 10 days then nothing for two weeks.

I miss the old Radio Times service - the Film reviews were extensive and often LOL. :)
CharlieBoy
Frequent contributor
Posts: 139
Joined: Sat Mar 04, 2006 3:39 pm

Post by CharlieBoy »

TopTapper wrote:I've just tried adding radio - 704 & 707; the channels seem to be picked up...... but there's no radio data.
Thanks for checking and replying. That's what I'm seeing by opening (in Excel) the xmltv.xml file output by mc2xml.exe. The radio channels are all listed there, but there's no programme data for any of them. So I guess the problem is either (1) that there is no radio programme data in the Microsoft Legacy EPG source, or (2) the data is there but mc2xml.exe is failing to gather it for some reason. My guess would be the former.

But at least you've confirmed that the problem isn't something I've inadvertently done - so thanks again for responding

Charlie
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -FmSy+UUu
TAPs: PcControl B1.4; MyInfo B5.6; EPG2MEI v0.96; MHEG On/Off A3; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; Deepletterbox 2.44; PruneEPG 1.0; MyStuff 6.6; (StartCh); (fsSave 1.1);
Sig generated by MyInfo on 14/4/18
?
leenoble
Frequent contributor
Posts: 297
Joined: Fri Dec 09, 2005 1:21 pm
Location: Cheshire, UK

Post by leenoble »

Can I ask people what settings they are using for both mc2xml and xml2mei, please.

Since I switched to this combination my Toppy frequently crashes on startup. I'll upload a new mei file and it'll be fine for a day or two, but then it'll start crashing again and the only way to resolve it is to delete the mei file.

My bash script looks like this:

Code: Select all

#!/bin/bash
mc2path="/path/to/my/mc2xml/directory"

"$mc2path/mc2xml" -C "$mc2path/mc2mei.chl" -d 176 -D "$mc2path/mc2xml.dat" -o "$mc2path/xmltv.xml"
php "$mc2path/xml2mei.php" -ep
and my channel list looks like this:

Code: Select all

1-15
17-21
21-34
37
41
44
46
47
48
54
60
62
64
65
66
68
70
74
79
83
96
120
121
122
127
130-132
135
I've steadily reduced the capture period so it's down to 176 hours which is barely over a week. I used to get the full 2 weeks with rt2mei or as2mei without any problems.

Thanks.
Toppy: TF5800PVR 250Gb; Firmware: 5.13.65T; Tx: Wenvoe;
Autostart TAPs: MyStuff 6.5, eit2mei BETA 7.8m3, SuperPiP;
Other Taps: HDFW [Af|Br|De|E2|Eg|Em|Fs|I|R3|Re|Sl|Vb|Vy|Wf|Xp], Channel Remover;
EPGmc2mei.
Bizman
Frequent contributor
Posts: 1707
Joined: Tue Apr 06, 2010 2:46 pm

Post by Bizman »

Those of you using Schedules Direct may be interested in some statistics:

1. The following LCNs are updated with 14 days of programmes on Saturdays: 1, 2, 3, 4, 5, 6, 9, 10, 14, 24, 28, 30, 54, 601

2. The following LCNs are updated with 21 days of programmes on Saturdays: 11, 17, (only 20 days for 74)

3. The following LCNs are updated with 13 days of programmes on Sundays: 15

4. The following LCNs are updated with 21 days of programmes on Mondays: 20, 31

4. The following LCNs are updated with 21 days of programmes daily: 37, 38, 41, 42, 46, 48, 60, 61, 64, 70, 72, 83

5. The following LCNs are updated with 16 days of programmes on Wednesdays: 12, 19,

6. The following LCNs are updated with 15 days of programmes on Fridays: 21

7. The following LCNs are updated with 20 days of programmes on Tuesdays & saturdays: 32

8. The following LCNs are updated with 18 days of programmes on Tues, Thurs or Saturday: 25

There is a degree of randomness to the figures and the schedules are modified almost daily.
TF5810, F/W: 5.15.09T 4/9/2009 -FmTe+EzHsVb
TAPs: EIT Sub (Game) v0.6; SecCache (UK) v0.4; MHEG On/Off A3; MPDisplayLITE V1.2; MyInfo B5.6; PruneEPG 1.0; EPG2MEI v0.96; QuickJump 1.72; Extend v1.7; (fsSave 1.1);
Sig generated by MyInfo on 3/8/17

Other TAPs : FsCheck, Channel Organiser. PSU Caps 7/2/2011 Tx: Mendip. TV: Samsung (32"), NSLU2, STB: Labgear FV300. PC Acer Aspire One with Win7 Starter
Bizman
Frequent contributor
Posts: 1707
Joined: Tue Apr 06, 2010 2:46 pm

Post by Bizman »

SD have now deemed that around half the films on Film4 are 'Premiere' even those going back to the 1950s. Someone's left a flag set.
TF5810, F/W: 5.15.09T 4/9/2009 -FmTe+EzHsVb
TAPs: EIT Sub (Game) v0.6; SecCache (UK) v0.4; MHEG On/Off A3; MPDisplayLITE V1.2; MyInfo B5.6; PruneEPG 1.0; EPG2MEI v0.96; QuickJump 1.72; Extend v1.7; (fsSave 1.1);
Sig generated by MyInfo on 3/8/17

Other TAPs : FsCheck, Channel Organiser. PSU Caps 7/2/2011 Tx: Mendip. TV: Samsung (32"), NSLU2, STB: Labgear FV300. PC Acer Aspire One with Win7 Starter
Bizman
Frequent contributor
Posts: 1707
Joined: Tue Apr 06, 2010 2:46 pm

Post by Bizman »

Further to the above, now all of the films on Film4 are marked as 'premiere'.

Another quirk I have noticed is an 'out by one' error on the number of episodes in a series, e.g S1 Ep 16/17 would be the last shown. At first I thought that the final episode had beed dropped, but this has occurred too many times in a variety of programmes, I have seen around 9 examples of this, ranging from series such as Star Trek, Voyager, South Park and The Man From U.N.C.L.E.

Could this be a bug in xml2mei?
TF5810, F/W: 5.15.09T 4/9/2009 -FmTe+EzHsVb
TAPs: EIT Sub (Game) v0.6; SecCache (UK) v0.4; MHEG On/Off A3; MPDisplayLITE V1.2; MyInfo B5.6; PruneEPG 1.0; EPG2MEI v0.96; QuickJump 1.72; Extend v1.7; (fsSave 1.1);
Sig generated by MyInfo on 3/8/17

Other TAPs : FsCheck, Channel Organiser. PSU Caps 7/2/2011 Tx: Mendip. TV: Samsung (32"), NSLU2, STB: Labgear FV300. PC Acer Aspire One with Win7 Starter
andyfras
Frequent contributor
Posts: 3484
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire
Contact:

Post by andyfras »

Does this work anymore? I just get "No new data available".
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
Bizman
Frequent contributor
Posts: 1707
Joined: Tue Apr 06, 2010 2:46 pm

Post by Bizman »

I used it this morning and did PotWk yesterday ok. I think there is a flag of some sort to override that. I vaguely recall it is on the login page where the key, programme source and other personal items are entered.
TF5810, F/W: 5.15.09T 4/9/2009 -FmTe+EzHsVb
TAPs: EIT Sub (Game) v0.6; SecCache (UK) v0.4; MHEG On/Off A3; MPDisplayLITE V1.2; MyInfo B5.6; PruneEPG 1.0; EPG2MEI v0.96; QuickJump 1.72; Extend v1.7; (fsSave 1.1);
Sig generated by MyInfo on 3/8/17

Other TAPs : FsCheck, Channel Organiser. PSU Caps 7/2/2011 Tx: Mendip. TV: Samsung (32"), NSLU2, STB: Labgear FV300. PC Acer Aspire One with Win7 Starter
TopTapper
Frequent contributor
Posts: 237
Joined: Sun Jan 29, 2006 4:18 pm

Post by TopTapper »

andyfras wrote:Does this work anymore? I just get "No new data available".
'Microsoft Legacy'? I've been seeing that since Jan-21 (a forced refresh made no odds).
leenoble
Frequent contributor
Posts: 297
Joined: Fri Dec 09, 2005 1:21 pm
Location: Cheshire, UK

Post by leenoble »

EDIT (save you reading on): It suddenly works again. It may have been a factor in fixing it that I deleted my dat file AND switched to a different lineup selection and then deleted it again and went back to my original YouView lineup.
-----

With the recent channel moves in my region, I've been forced to update all my settings to get the full EPG back again. I'm in Wales and I'm seemingly not getting data for Channel 4 or Channel 5.
Concentrating on C4 for the moment, in Wales it's broadcast on lcn 7 as S4C is on lcn 4.
I've even tried deleting the chl file that schedules direct uses to limit the channels being fetched, but after running mc2xml and xml2mei there's still nothing listed for lcn 7.

Here are the two commands I'm running:

Code: Select all

./mc2xml -J username&#58;password -U -C mc2mei.chl -c gb -g CF10 -d 176 -D mc2xml.dat -o xmltv.xml

php xml2mei.php -ep -v
Am I right in thinking that xml2mei no longer needs an external cfg file?

My xml file from SD contains this:

Code: Select all

	<channel id="I7.17155.schedulesdirect.org">
		<display-name>7 C4</display-name>
		<display-name>7</display-name>
		<display-name>C4</display-name>
		<display-name>Channel 4</display-name>
		<display-name>C4HD</display-name>
		<icon src="https&#58;//s3.amazonaws.com/schedulesdirect/assets/stationLogos/s17155_h3_aa.png" width="360" height="270" />
	</channel>
but there don't appear to be any programmes with that channel id. I7.17155 doesn't appear anywhere else in the file which makes me think it's an SD problem but not sure how to resolve it, if I can.
Toppy: TF5800PVR 250Gb; Firmware: 5.13.65T; Tx: Wenvoe;
Autostart TAPs: MyStuff 6.5, eit2mei BETA 7.8m3, SuperPiP;
Other Taps: HDFW [Af|Br|De|E2|Eg|Em|Fs|I|R3|Re|Sl|Vb|Vy|Wf|Xp], Channel Remover;
EPGmc2mei.
EMJB
Frequent contributor
Posts: 3645
Joined: Fri Jul 08, 2005 9:43 am
Location: Maldon Essex

Post by EMJB »

In case anyone else couldn't remember what to do when they got the email from Schedules Direct about package reorganisations, this what I did:

(1) Delete (or rename) mc2xml.dat on my PC

(2) Run mc2xml.exe selecting Schedules Direct JSON data, enter your Schedules Direct username & password, and then relevant region.

(3) If not using the PC to collect the data, copy mc2xml.dat to wherever your Schedules Direct data is collected, overwriting the old version. (I collect the data with a Raspberry Pi).

EMJB
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
Post Reply