For questions, answers and tips aimed at new users, or those thinking about buying a Toppy

Moderators: General, Technical

Post Reply
RobinT50
Posts: 6
Joined: Thu Oct 13, 2005 8:42 am

Has my Toppy failed?

Post by RobinT50 »

I have had my Toppy for 8 or 9 years and it has operated more or less flawlessly until I had to move it a few days ago. It now seems to have failed. On startup the text gets as far as 'run' and then hangs. Sometimes it gets to 'MENU' and the last time it did this I did a factory reset and channel search and all seemed OK. Turned it off and on a couple of times still OK. Then turned it off and left it for a few minutes and it's now back to hanging at the 'run' text.

Has anyone any ideas?

Thanks in advance,

Robin Trow
andyfras
Frequent contributor
Posts: 3486
Joined: Mon Jul 25, 2005 2:41 pm
Location: Fleet, Hampshire
Contact:

Post by andyfras »

The PSU capacitors have failed.

See: http://forum.toppy.org.uk/forum/viewtopic.php?t=19103

I can fix it, or supply you with a kit for DIY if you, or someone you know, can solder.

I strongly suggest that you switch it off at the mains until it is repaired, otherwise you risk damage to the disk and/or mainboard.
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
Post Reply