General discussion relating to Topfield products for the Australian market

Moderators: General, Technical, Oz mods

Post Reply
inglewoodpete
Posts: 13
Joined: Fri Mar 19, 2010 3:08 pm

TRF-2400 User Guide and Firmware

Post by inglewoodpete »

I have been having trouble with my one year old TRF-2400. Recently, the Toppy seems to have IR lockups where it stops responding to the remote control.

Scenario: we're watching TV via the 2400 and the Front Display has dimmed to the Standby mode. Nothing but persistant button pressing on the remote handpiece seems to 'wake' the box from this mode. This can take several minutes. Suddenly the 2400 responds and everything returns to normal: all menus etc appear to work normally. Until recently, the box responded immediately to the remote.

I have checked the handpiece (The original Topfield part supplied with the 2400) with a camera and the IR LEDs are flashing as expected.

I have dug out the manual that I downloaded when I bought the 2400 and I have found that it is not up to date compared to (at least) the setup menus. My current firmware is TF-BCPF 1.23.00, dated Jan 7 2013.

The Australian Topfield site seems to be down. http://www.itopfield.com.au/ has not been responding for the last week. Messages on other forums that I have read suggest longer. Are there other sites where firmware and manuals for the TRF-2400 can be downloaded?

Put simply, I want the remote control to work when I press a button. Does anyone have any experience with how to rectify my problem? It appears to be a firmware or configuration issue.
Last edited by inglewoodpete on Thu Apr 25, 2013 3:11 pm, edited 1 time in total.
Referee
Posts: 22
Joined: Wed Sep 30, 2009 8:55 am
Location: Wollongong, Australia

Post by Referee »

Hi,

Hope these posts help you.

http://www.dtvforum.info/index.php?show ... try1881874

General stuff about the site being down,

and

http://www.dtvforum.info/index.php?show ... try1881803

for the 2400 Guide.

Also

Drop a post in here, as Ian may help your sourcing a firmware

http://www.dtvforum.info/index.php?show ... 8361&st=25

Notice that you have already posted on other forums seeking help as well.

My 2400 is working fine, must check on the firmware it is running.

8)
--------------------
Cheers from Mike
TF7100HDPVRt
SysID: 32050: F/W 20090317.upd + Ext HDD 1TB WD Elements
TF5000PVRtMasterpiece
SysID: 1426, F/W: 5.13.25B2DDeHrIMkRR5RpTsWfXpXwXl
TAPs: Filer v2.31; 3PG 1.28; TSRCommander 1.5; QuickJump 1.72; MyInfo B5.5;
Sig generated by MyInfo on 23/2/11
inglewoodpete
Posts: 13
Joined: Fri Mar 19, 2010 3:08 pm

Post by inglewoodpete »

Thanks for the feedback Mike,

I keep trying the Australian Topfield website with fingers crossed but no luck yet.

I updated the firmware in early March (to the Jan 2013 version) if my memory serves me right. It had performed fairly well until a couple of weeks ago.

Thanks for the link to the User Guide. That is the 2009 version (Rev.1) I have the 2010 version (Rev.2) and that is out of date when it comes to the configuration menus. I'm looking for a Rev 3 at least.

Since starting this thread I tried a factory reset. Instant fix! Bit it started misbehaving again after a day or so. It then gets progressive worse: first a couple of button presses to wake the Topfield. When it got to over 60 button presses on the remote, about 4 days after the first reset, I did another factory reset. Same result and it's already starting to misbehave just 24 hours later.

I'm an analyst/programmer by trade and it's behaving just like it has buggy software but this firmware ran quite well for over a month.

Three problems I noticed with the 2400 in the last couple of months:
  • * Occasional timeshift lockups where recording stops (I leave the box running 24x7)
    * This week, the box just rebooted without warning while I was watching one channel and recording another.
    * And, of course, the cranky IR receiver.
I've just checked my paperwork and I took delivery of the 2400 one year yesterday (DOP 24-April-2012). One-year warranty: hmm time to make an urgent call to the Topfield helpline!

I can't find any of old copys of the firmware so that I could try them. I'll join the DTV forum if I don't get sufficient joy from the Topfield helpline.

Peter
juwlz
MyStuff Team
Posts: 10804
Joined: Fri Aug 12, 2005 7:13 am
Location: Wokingham, Berkshire (Hannington transmitter)
Contact:

Post by juwlz »

If it's anything like UK firmware, putting it into standby when it's not in use (or at least every night) helps deal with any memory leaks.

Julie
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
Referee
Posts: 22
Joined: Wed Sep 30, 2009 8:55 am
Location: Wollongong, Australia

Post by Referee »

inglewoodpete wrote:
Thanks for the link to the User Guide. That is the 2009 version (Rev.1) I have the 2010 version (Rev.2) and that is out of date when it comes to the configuration menus. I'm looking for a Rev 3 at least.

....

I can't find any of old copys of the firmware so that I could try them. I'll join the DTV forum if I don't get sufficient joy from the Topfield helpline.

Peter
Peter I have the following Guide on my PC.
TRF-2400-Eng-e9926

The Guide for the 2460 is also suitable as the only difference between it and the 2400 is the HDD size. There was a link on one of my earlier posts to that guide 2460 that is.

Firmware wise I have
TRF-2400_AUST_32020-2012Feb20_v1.17.00

You can PM me an email address and I can forward for you if you want.
:wink:
--------------------
Cheers from Mike
TF7100HDPVRt
SysID: 32050: F/W 20090317.upd + Ext HDD 1TB WD Elements
TF5000PVRtMasterpiece
SysID: 1426, F/W: 5.13.25B2DDeHrIMkRR5RpTsWfXpXwXl
TAPs: Filer v2.31; 3PG 1.28; TSRCommander 1.5; QuickJump 1.72; MyInfo B5.5;
Sig generated by MyInfo on 23/2/11
inglewoodpete
Posts: 13
Joined: Fri Mar 19, 2010 3:08 pm

Oops.

Post by inglewoodpete »

I think I have egg on my face :roll:. Last Friday, after calling the Topfield helpline (details below), I reset the remote control (handpiece) - no improvement. Then, to eliminate the remote, I replaced the batteries - bingo! Instant result. Oh boy, now I had to explain that to the forum: I didn't want to cast aspersions on the 2400 or the firmware if those were not the problem.

So, to be clear, the Jan 7 2013 firmware (V1.23) does not appear to have any infrared bugs as I implied in earlier posts.

The call to the Topfield Support Line started in the way that so many calls to businesses do these days: A 20 minute wait while entertained by two competing recorded voices. One of the voices was telling me to go to the (offline) website first. The amusing part was the call status messages: I started off 4th in the queue, next, second and then relegated to 3rd!! before the call was answered by a slightly stressed operator (I don't envy the job.)

The helpline's suggestions: reset the remote then try new batteries. At the time, I was convinced that the problem was in the box, so quizzed the guy on what he thought was the best firmware alternative. His suggestion was the October 2012 revision (v1.22) and later provided details via email on how to install the Dropbox file. I also asked about the Australian website and was told that it should be up "in about a week". I sure hope so. No complaints about the assistance, apart from the wait.

The technician in me is a bit mystified by the behaviour of the remote control with fading batteries. Initially, the remote needed a couple of button presses before it would work - then it would keep working. When tried again later, it would gradually require more presses to wake it up, then would would keep working. Conventional thinking suggests that the batteries would get flatter with each press on a button. I can only assume that the handpiece has some sort of voltage doubler circuit to drive the IR LEDs: with constant use, the higher voltage is maintained but drops below a workable level when used intermittantly. A lesson for me in there somewhere.

Julie, I have found that regular standby shutdowns help keep things more stable, too. Thanks for confirming this. My older TF4400PVRt SD PVR, used with our second TV, needs to be powered down (actually unplugged) periodically.

Mike, Thanks for the offer of software and manual. I now have a copy of v1.22 (Oct '12) courtesy of the Topfield tech helpdesk. I'd like to pursue the User Guide further. My User Guide, identified on the last page as 110T-C5AC6-701-2(Rev.2) Copyright 2010 is not up to date with the latest firmware.

I still love my Topfields but find the bugs annoying. I expect I will get timeshift lockups and possibly an occasional spontaneous reboot in the 2400 if I don't downgrade the firmware. I like to be able to access YouTube (the reason for my Jan 2013 update) but will forgo YouTube if it means getting a more stable and reliable PVR. TAPs are not a priority for me at the moment. The 2400 has been on the market for several years and should have a stable operating system by now.
juwlz
MyStuff Team
Posts: 10804
Joined: Fri Aug 12, 2005 7:13 am
Location: Wokingham, Berkshire (Hannington transmitter)
Contact:

Re: Oops.

Post by juwlz »

inglewoodpete wrote:I still love my Topfields but find the bugs annoying. I expect I will get timeshift lockups and possibly an occasional spontaneous reboot in the 2400 if I don't downgrade the firmware. I like to be able to access YouTube (the reason for my Jan 2013 update) but will forgo YouTube if it means getting a more stable and reliable PVR. TAPs are not a priority for me at the moment. The 2400 has been on the market for several years and should have a stable operating system by now.
Be grateful you have the choice. Topfield abandoned the UK market years ago, and it's only because forum users have contributed firmware patches and hardware repairs that ours keep running at all. The closest we get to networking is via USB. The ("up to date") firmware I have on mine is dated Sept 2009.

Julie
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
inglewoodpete
Posts: 13
Joined: Fri Mar 19, 2010 3:08 pm

Question on a new topic?

Post by inglewoodpete »

Sorry I'm reviving an old thread but at least it's my own!

I've got a new topic (TRF-2400 is on the blink) but can't see a link or button to start a new thread anywhere. Luckily I can post to an old thread!

Windows 7/64 and IE11. Where should I see the link or button? Oz Toppies forum, of course.

Peter

:oops: Oh poop. Just found it. Stand by for new topic...
ccs
Frequent contributor
Posts: 2689
Joined: Tue Oct 30, 2007 3:19 pm

Post by ccs »

Go to OZ Toppies, scroll to bottom of page, new post bottom left.
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
Post Reply