For discussions related to MyStuff and associated TAPs, including eit2mei and MEI Search

Moderator: Technical

Post Reply
scuda
Regular contributor
Posts: 29
Joined: Sun Nov 13, 2005 6:21 pm

EPG2mei tap list shows gobbledy-gook

Post by scuda »

Earlier today switched on Toppy 5810 and most timer list progs are rubbish characters.
Tried deleting (Z2) and restarting, but the list still comes up rubbish.
Can anyone help, please?

Scuda
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; EPG2MEI v0.96; PruneEPG 1.0;
Sig generated by EMJB's MyInfo.tap on 26/3/19
â„¢
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

https://ukfree.tv/transmitters/tv/Huntshaw_Cross says that they were doing some work today.

Suggest you switch the toppy off (in case file system gets corrupted) until they have finished (5pm say) and then reboot. Wait 25 mins while EPG rebuilds and see if EPG resolves itself.


Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
scuda
Regular contributor
Posts: 29
Joined: Sun Nov 13, 2005 6:21 pm

Post by scuda »

Geoff, Thanks for that, didn't think to check local xmitter before posting.
Will post if that proves to be the problem.

most appreciated,
scuda
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; EPG2MEI v0.96; PruneEPG 1.0;
Sig generated by EMJB's MyInfo.tap on 26/3/19
â„¢
scuda
Regular contributor
Posts: 29
Joined: Sun Nov 13, 2005 6:21 pm

Post by scuda »

More info to my original post:

I have found that ALL of my Freeview equipment (TVs and 2 x Toppy 5810) is affected by the problem, exception being my latest Panasonic TV?

The problem I see is that 90% of the EPG programme titles and descriptions are made up of unintelligible characters (a charachter set not interpreted by equipment EPG handler?) Not all channels are affected completely, so some info is processed OK.

The toppy seems to be recording one-time and series progs OK, although I have to choose progs only by time of day (titles garbled).

In addition to using Z2 to clear EPG, I have done a manual re-tune, result the same. I have also posted a query on UKTVFree on Huntshaw Cross page, no reply so far (it shows that there was work done on Tues 12/Wed 13 between midnight Tues and 04.30 Wed) Have they buggered up EPG?

Does anyone else using Huntshaw Cross have this problem?
Scuda
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; EPG2MEI v0.96; PruneEPG 1.0;
Sig generated by EMJB's MyInfo.tap on 26/3/19
â„¢
scuda
Regular contributor
Posts: 29
Joined: Sun Nov 13, 2005 6:21 pm

Post by scuda »

My latest efforts:

Have tried re-installing MyStuff using GCBMyStuffinstaller, did not fix the problem.

As my toppys do an EPG collection scan between 02.30 and 03.00, I now think that when the xmitter was off, from 00.07 to 04.30, the lack of signal screwed the toppy itself.

I intend to reset to factory setting, reformat disk and re-install MyStuff (need to copy off all recordings first)

I cannot do this during the next week, but will return to this post with update.

I have read Micheal's comments on another post, thanks for that!

Scuda
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; EPG2MEI v0.96; PruneEPG 1.0;
Sig generated by EMJB's MyInfo.tap on 26/3/19
â„¢
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

Before you do all that, suggest you use TopManager | Tools| remove Bad EPG filesto see if that fixes it (you will need to wait 25 mins for the EPG to rebuild)

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
DevonDave
Posts: 2
Joined: Mon Mar 18, 2019 10:12 pm

Issue cleared

Post by DevonDave »

Hi, my 2 TF5800 are now showing epg data. My older Sony TV would not load epg off the BBC mux but ITV was fine. Now all are correct without reload or setting wipe.

Cheers

Dave
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

@DevonDave

did you do anything or did it just sort itself out?

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

I think I can surmise how all this happened.

Basically,
1) EPG data is sent in small packets by the broadcaster. These packets are automatically stored in memory by the toppy (a native mechanism). Note: PruneEPG may intercept and discard packets not associated with a tuned channels.
2) Periodically, and when the EPG is not rapidly changing, EPG2MEI scans the in memory EPG and writes out EPG files for MyStuff to use. When writing these files, EPG2MEI also makes use of any existing previously stored files (I believe this is to minimise changes sent to MyStuff). After creating the files, EPG2MEI notifies MS that new data is available.

Under normal circumstances, using MyStuff option Z2 (?) and/or TopManager Tools| Remove Bad EPG files work fine - they just delete the stored EPG files and MS waits for EPG2MEI to generate new versions. This mechanism handles the situaton where the EPG files on the disk contain corrupted data.

However, it should be noted that when EPG2MEI regenerates the data, it will base it on the EPG packets stored in the native EPG buffer. i.e. if this still contains corrupted data sent by the broadcaster then this will propagate to the new data files.

So, when the broadcaster has been sending out bad EPG data, one needs to do the following:
1) Check on a TV EPG to determine when the broadcaster has fixed the problem
2) Delete the EPG files (MS option Z2 or use TopManager)
3) Clear the EPG buffer by immediately rebooting the toppy (before EPG2MEI has hasdtime to recreate the files)
4) Say no to entering MyStuff Recovery mode (if prompted)
5) Wait 20 mins for the EPG to regenerate

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
DevonDave
Posts: 2
Joined: Mon Mar 18, 2019 10:12 pm

SD vs HD

Post by DevonDave »

Hi Geoff,

As an observation it was only my SD devices that were corrupted, HD TV and Panasonic PVR were fine.

Maybe the data stream on the SD was the issue, and they fixed it.

Regards

Dave [/quote]
scuda
Regular contributor
Posts: 29
Joined: Sun Nov 13, 2005 6:21 pm

Post by scuda »

Hi Geoff,

Back today after being away for a week.
Looking at progs recorded since being away, it seems that from Tuesday 19th everything was OK, all titles and descriptions legible. So I will not be re-formatting or reinstalling.
I notice that there are a few people raising this issue on the Huntshaw Cross section of UKTVFREE.

Thanks for looking into the workings of EPGMEI and suggesting a remedy. I will keep that info handy!

Scuda
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: PcControl B1.4; MyStuff 6.6; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; EPG2MEI v0.96; PruneEPG 1.0;
Sig generated by EMJB's MyInfo.tap on 26/3/19
â„¢
Geoff Bacon
Frequent contributor
Posts: 4663
Joined: Fri Jan 12, 2007 12:21 am
Location: Bristol
Contact:

Post by Geoff Bacon »

@scuda

That's good news; reinstalling anything would have been unlikely to have made any improvement.

Geoff
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPePfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; MHEG On/Off A3; QuickJump 1.72; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; WSSkiller V2.12d; MyInfo B5.6; fsSave 1.1; PruneEPG 1.0; MyStuff 6.6-1;
Sig generated by EMJB's MyInfo.tap on 3/5/21
Post Reply