Click here to go to the forum index Click here for the home page
 
Author Message

<  General Toppy discussions  ~  Where's my disk gone ??? Oh, there it is.

Page 1 of 1
gingerly
Posted: Thu Dec 11, 2014 10:50 am Reply with quote
Regular contributor Joined: 03 Jan 2007 Posts: 76 Location: South London
It's happened only twice, so far.

The toppy wakes up (presumably) for a recording, but the disk is non functional and it just sits there until we find it some hours later.
When we check it there is no filesystem. A quick reboot and it's absolutely fine, no VF&F and only missing the recordings that it missed whilst it was away with the fairies.

I changed most of the caps in the psu and the HD to a 1TB ecogreen drive about 4 years ago and its been runnning very smoothly and cool since then. (well, apart from film4+1 crashing it daily until we rescanned)

Any suggestions where I should be looking for clues ?

Lee.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+R3VdWfZ
TAPs: QuickBlank 0.2; UK Subtitle 1.9; TF5000 Display v1.53; Goldfish 0.5; Extend v1.7; MyStuff 6.5; EPG2MEI v0.96; SecCache (UK) v0.4; Font Manager 1.0d; EIT Sub (Game) v0.6; MyInfo B5.5;
Sig generated by MyInfo on 10/12/14
?
View user's profile Send private message
andyfras
Posted: Thu Dec 11, 2014 11:55 am Reply with quote
Frequent contributor Joined: 25 Jul 2005 Posts: 3463
gingerly wrote:
I changed most of the caps in the psu and the HD to a 1TB ecogreen drive about 4 years ago...

Any suggestions where I should be looking for clues ?

Change the rest of the capacitors, or all of them if the replacements were not top quality (e.g. Maplin ones don't last long).

I always install a link to slow down the interface on SATA drives (5-6 on a WD). I've no proof that this has any effect, but it should be one less bit of hand-shaking on start-up. When I have put one of these drives in a Humax, it's not recognised at all unless the link is in place.

_________________
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
View user's profile Send private message Visit poster's website
gingerly
Posted: Wed Feb 11, 2015 6:41 pm Reply with quote
Regular contributor Joined: 03 Jan 2007 Posts: 76 Location: South London
Two months on and time for an update.

According to the Linux box attached via USB to the Toppy ...
- the toppy always wakes up when it should,
- but every two weeks or so there is no hard disk.
I've had a script running which reboots the Toppy if it has no disk.
When it does the HD is back again, but unfortunately the toppy takes about 4 minutes before it will respond via USB, presumably waiting for the disk and timing out on it.
By this time the timer has gone and the recording missed,
but where there's another chance to record the programme, Mystuff does its thing.

Anyway, today I replaced *ALL* the PSU caps, thanks for the kit Andy!
The HD I have (HD103SI) can't be told by jumpers to use SATA1 (need to use a software tool) so I have left it as is.

If I continue to have problems maybe I should try to raise my 3.3v line which is now down at 3.21v. The spec for the KA278R33 says that it produces a minimum of 3.22v and so mine is now below this (or meter error). The highest mine has ever been was back in 2010 when it was 3.23v

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+R3VdWfZ
TAPs: QuickBlank 0.2; UK Subtitle 1.9; TF5000 Display v1.53; Goldfish 0.5; Extend v1.7; MyStuff 6.5; EPG2MEI v0.96; SecCache (UK) v0.4; Font Manager 1.0d; EIT Sub (Game) v0.6; MyInfo B5.5;
Sig generated by MyInfo on 10/12/14
?
View user's profile Send private message
ccs
Posted: Wed Feb 11, 2015 7:02 pm Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2602
I found that a newlink adapter +5810 + hdmi tv connection would sometimes (fairly regularly) load up without the HD.

Clearly at least 2 of these variables are not appropriate.

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
Geoff Bacon
Posted: Wed Feb 11, 2015 7:15 pm Reply with quote
Frequent contributor Joined: 12 Jan 2007 Posts: 4444
You might find FireBirds [D] HDD Detection patch helps.

If not, the [We] patch wakes the toppy 10 minutes early to service a timer (never used it)

Geoff

_________________
TopManager program
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; PruneEPG 1.0; fsSave 1.1; QuickJump 1.72; SecCache (UK) v0.4; EIT Sub (Game) v0.6; EPG2MEI v0.96; MyStuff 6.6; Bookmark 3.0; Extend v1.7; Font Manager 1.0d; MyInfo B5.6; MHEG On/Off A3;
Sig generated by EMJB's MyInfo.tap on 29/12/18
View user's profile Send private message Visit poster's website
ccs
Posted: Wed Feb 11, 2015 8:36 pm Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2602
Geoff Bacon wrote:
If not, the [We] patch wakes the toppy 10 minutes early to service a timer (never used it)
[We] needs some careful reading, but really only for freeview+ firmware. Might be ok.

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
gingerly
Posted: Wed Feb 11, 2015 11:45 pm Reply with quote
Regular contributor Joined: 03 Jan 2007 Posts: 76 Location: South London
CCS : ah, but the newlink adapter is. Hmmm.
But its been working without issue for years!

Geoff : Thanks, I didn't know these existed.
If I can't find and fix the root cause, I will be looking at these.

CCS : thanks for the warning about the [We] patch.
Apparently it can be applied to any firmware,
but it isn't compatable with the [T2] timer patch.
I find that scary as the timer patch seemed to make a big difference
to us getting reliable recordings. So I'm not keen on removing it!

Andy : Are you there? Do you mind me picking your brain?
I have measured 5V on one end of R22 and 3.72v on the other.
Surely that means that my 3.3v voltage reg is only being fed 3.72v
and so its no wonder it can only manage to output 3.21v (0.5v drop)
Should I be checking L6 and D11? If so, how? Any suggestions gratefully received.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+R3VdWfZ
TAPs: QuickBlank 0.2; UK Subtitle 1.9; TF5000 Display v1.53; Goldfish 0.5; Extend v1.7; MyStuff 6.5; EPG2MEI v0.96; SecCache (UK) v0.4; Font Manager 1.0d; EIT Sub (Game) v0.6; MyInfo B5.5;
Sig generated by MyInfo on 10/12/14
?
View user's profile Send private message
andyfras
Posted: Thu Feb 12, 2015 9:14 am Reply with quote
Frequent contributor Joined: 25 Jul 2005 Posts: 3463
3.7V is typical at the junction of R22 and pin 1 of V3. The 3.3V is regulated down to 1.5V on the mainboard to feed the main processor. 3.21V is well within 5%, so it is unlikely to be an issue.

_________________
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
View user's profile Send private message Visit poster's website
gingerly
Posted: Thu Feb 12, 2015 9:50 am Reply with quote
Regular contributor Joined: 03 Jan 2007 Posts: 76 Location: South London
Thanks Andy for the quick reply, I'll leave it alone then.

It shows that I just don't understand the design.
I have not previously seen a voltage reg intentionally run at its minimum input voltage.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+R3VdWfZ
TAPs: QuickBlank 0.2; UK Subtitle 1.9; TF5000 Display v1.53; Goldfish 0.5; Extend v1.7; MyStuff 6.5; EPG2MEI v0.96; SecCache (UK) v0.4; Font Manager 1.0d; EIT Sub (Game) v0.6; MyInfo B5.5;
Sig generated by MyInfo on 10/12/14
?
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 1

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum