Click here to go to the forum index Click here for the home page
 
Author Message

<  MyStuff  ~  Weird, non-serious(?) display bug

Page 1 of 2
Goto page 1, 2  Next
birdman
Posted: Sat May 21, 2011 12:51 am Reply with quote
Frequent contributor Joined: 13 Dec 2006 Posts: 1765 Location: Hitchin, HERTS Tx: Sandy Heath
I've just come across a weird, non-serious(?) display bug.

I listed my scheduled timers, and noticed that one was set to run from "00:0 " to "0108" on Tuesday morning. Turns out that the start time is really "00:08" (I can check this when I edit it), but there's a space on the display.

So I tried changing it slightly.

At 00:00 it reckons it's recording to the previous programme to (the one being recorded really starts at 00:05), but displays OK, as do 00:01, 00:02, 00:04, 00:05, 00:07, 00:10 and 00:13. But 00:03, 00:06, 00:08 and 00:09 all show as "00: ".

Ah - seems that this is a result of the Font I'm using in FontManager (as switching that off gets the full time back). So it looks like 0, 3, 6, 8 and 9 are slightly "fatter" that the rest and together over-fill the column width? (I thought all numerals were the same width even in proportional typefaces).

_________________

Toppy: TF5800PVR/250 - Black, now 1TB WD10EURX
F/W: MS6 Recommended F/W 12/9/2009 -FmVrXp+BmC0CbFsIPsUUuWfZXl,
Loader: C5.14, Hardware: 1.01
TAPs: SecCache (UK) v0.4; EPG2MEI v0.96; FontManager 1.0d; QuickJump 1.71; MhegOnOff(Now1) A3; EIT Sub v0.6; MyStuff 6.6
USB connected: SheevaPlug with Debian wheezy
Sig mostly from MyInfo on 26/10/09
View user's profile Send private message
Iken
Posted: Sun May 22, 2011 1:10 pm Reply with quote
Frequent contributor Joined: 13 Jul 2006 Posts: 109 Location: Hertfordshire, Sandy Heath Tx
I had exactly this problem, using my preferred Arial Narrow font.
Changing it to another via Font Manager's options sorted the display issue, so I set about reducing the size of the small and medium sizes of Arial Narrow to match the other font; all is now well, and the text no longer requires X/Y adjustment in MyStuff options.

Hope that's helpful...

[edit] typo... Embarassed


Last edited by Iken on Tue May 24, 2011 6:28 pm; edited 1 time in total

_________________
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009 -R+BmC0DsEvIMPeR0UUuUyVyZ
Autorun TAPs: Power Restore V0.7.8; MHEG Control B2.1; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Extend v1.7; Font Manager 1.0d; TF5000 Display v1.53; MyStuff 6.5; MyInfo B5.6.
Manual TAPs: ChannelOrganiser B2X10; FwLoad B3.3; HDD Info V2.4d; SignalMonitor 0.54; TAP Commander 1.34.

Last Updated 21/10/2013
?
View user's profile Send private message
BobD
Posted: Sun May 22, 2011 1:27 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
@birdman, which font were you using? It should work for all fonts, as the code does try to cope with all widths.

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
birdman
Posted: Tue May 24, 2011 12:03 am Reply with quote
Frequent contributor Joined: 13 Dec 2006 Posts: 1765 Location: Hitchin, HERTS Tx: Sandy Heath
BobD wrote:
@birdman, which font were you using?
LiberationSans regular

_________________

Toppy: TF5800PVR/250 - Black, now 1TB WD10EURX
F/W: MS6 Recommended F/W 12/9/2009 -FmVrXp+BmC0CbFsIPsUUuWfZXl,
Loader: C5.14, Hardware: 1.01
TAPs: SecCache (UK) v0.4; EPG2MEI v0.96; FontManager 1.0d; QuickJump 1.71; MhegOnOff(Now1) A3; EIT Sub v0.6; MyStuff 6.6
USB connected: SheevaPlug with Debian wheezy
Sig mostly from MyInfo on 26/10/09
View user's profile Send private message
MarkPax
Posted: Tue May 24, 2011 7:23 am Reply with quote
Frequent contributor Joined: 07 Nov 2010 Posts: 520
I've seen this with MS 6.3 too, with the clock top right of the EPG, if the first character is a 1 sometimes it appears with a wider font than the other characters. I use Tahoma Narrow. I've not seen it with timers as described by the OP. In my clock case it doesn't bug me at all but I can imagine the timer problem could be more annoying.

_________________
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009 +PeR0UUuWfZ
TAPs: TAP Commander 1.34; TommyFF v2.1; BlankStuff v2.5; MyInfo B5.5; EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub v0.6; TF5000 Display v1.53;
Sig generated by MyInfo on 19/5/11
View user's profile Send private message
BobD
Posted: Tue May 24, 2011 7:56 am Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
birdman wrote:
BobD wrote:
@birdman, which font were you using?
LiberationSans regular
Can you please email me the actual font file(s)?

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
birdman
Posted: Tue May 24, 2011 11:46 pm Reply with quote
Frequent contributor Joined: 13 Dec 2006 Posts: 1765 Location: Hitchin, HERTS Tx: Sandy Heath
BobD wrote:
Can you please email me the actual font file(s)?
Yes - if you PM me your mail address....

_________________

Toppy: TF5800PVR/250 - Black, now 1TB WD10EURX
F/W: MS6 Recommended F/W 12/9/2009 -FmVrXp+BmC0CbFsIPsUUuWfZXl,
Loader: C5.14, Hardware: 1.01
TAPs: SecCache (UK) v0.4; EPG2MEI v0.96; FontManager 1.0d; QuickJump 1.71; MhegOnOff(Now1) A3; EIT Sub v0.6; MyStuff 6.6
USB connected: SheevaPlug with Debian wheezy
Sig mostly from MyInfo on 26/10/09
View user's profile Send private message
BobD
Posted: Wed May 25, 2011 7:52 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
Ta. Archive problem duplicated with this font. Should be easy to fix. Will look at the clock issue too, though I haven't been able to duplicate that one yet.

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
BobD
Posted: Wed May 25, 2011 8:08 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
Archive problem fixed;

@MarkPax - does the clock problem on the EPG show as soon as you display the EPG, or only if it comes up, and you leave it on for long enough for the time to change to something that does not fit in the reserved area?

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
MarkPax
Posted: Thu May 26, 2011 7:53 am Reply with quote
Frequent contributor Joined: 07 Nov 2010 Posts: 520
BobD wrote:
@MarkPax - does the clock problem on the EPG show as soon as you display the EPG, or only if it comes up, and you leave it on for long enough for the time to change to something that does not fit in the reserved area?

Don't think so, will check. From memory it only seems to happen if you monkey around in the menus a lot and go in to and out of the EPG loads of times. Not sure I've seen it in 6.4 yet.
Excuse to buy a bigger telly so I can see it properly??? Wink

_________________
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009 +PeR0UUuWfZ
TAPs: TAP Commander 1.34; TommyFF v2.1; BlankStuff v2.5; MyInfo B5.5; EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub v0.6; TF5000 Display v1.53;
Sig generated by MyInfo on 19/5/11
View user's profile Send private message
Black Cloud
Posted: Sat Apr 14, 2012 6:35 pm Reply with quote
Frequent contributor Joined: 18 Sep 2005 Posts: 300
I am having a similar display problem in the Timer menu, with some start and finish times being incomplete because some numbers appear wider than others. I am using Font Manager and have selected the tahomaNarrow18 font.

Will the fix be released soon? Or did I miss it somehow?

_________________
HW: TF5800 Black Panther 1.5TB. FW: 5.13.65 Patched
SW: TAP Commander 1.32, Goldfish 0.5, Font Manager 1.0d, SecCache v0.4, EIT Sub v0.6, EPG2MEI v0.96, Extend v1.7, TF5000 Display v1.53, MyStuff 6.4, MHEG On/Off A3, WSSkiller V2.12d
View user's profile Send private message
BobD
Posted: Sat Apr 14, 2012 7:08 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
I didn't think there were any of these type bugs outstanding. What start and end times are not showing?

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
BobD
Posted: Sat Apr 14, 2012 8:10 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4218
Mind you, MS 6.4 was released 17th May 2011, which is before I posted that I had fixed the problem, so the fix must be in the internal builds, so you have not missed anything.

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
Black Cloud
Posted: Sat Apr 14, 2012 8:18 pm Reply with quote
Frequent contributor Joined: 18 Sep 2005 Posts: 300
The problem is in the Timers by Date and in the Timers by Name screens, like this, for example:
Code:

BGT             Sat  14/4  19:58 - 21:2
Fast+Furious    Sat  14/4  22:1  - 23:1
Daily EPG       Daily      07:0  - 07:1
Burn Notice     Sun  15/4  16:13 - 17:21

I have 31 current timers, and Burn Notice is the only timer that displays correctly.

BTW I omitted the Durations from above as they are fine. The archive screen is fine too.


Last edited by Black Cloud on Sat Apr 14, 2012 8:23 pm; edited 1 time in total

_________________
HW: TF5800 Black Panther 1.5TB. FW: 5.13.65 Patched
SW: TAP Commander 1.32, Goldfish 0.5, Font Manager 1.0d, SecCache v0.4, EIT Sub v0.6, EPG2MEI v0.96, Extend v1.7, TF5000 Display v1.53, MyStuff 6.4, MHEG On/Off A3, WSSkiller V2.12d
View user's profile Send private message
Black Cloud
Posted: Sat Apr 14, 2012 8:20 pm Reply with quote
Frequent contributor Joined: 18 Sep 2005 Posts: 300
BobD wrote:
Mind you, MS 6.4 was released 17th May 2011, which is before I posted that I had fixed the problem, so the fix must be in the internal builds, so you have not missed anything.

OK, I guess I'll have to wait a bit longer then... Very Happy

_________________
HW: TF5800 Black Panther 1.5TB. FW: 5.13.65 Patched
SW: TAP Commander 1.32, Goldfish 0.5, Font Manager 1.0d, SecCache v0.4, EIT Sub v0.6, EPG2MEI v0.96, Extend v1.7, TF5000 Display v1.53, MyStuff 6.4, MHEG On/Off A3, WSSkiller V2.12d
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 2
Goto page 1, 2  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum