Click here to go to the forum index Click here for the home page
 
Author Message

<  Firmwares, enhancements and upgrades  ~  SATA-IDE converters, working and non-working models

Page 16 of 18
Goto page Previous  1, 2, 3 ... 15, 16, 17, 18  Next
tfu
Posted: Sun Sep 16, 2012 4:51 pm Reply with quote
Regular contributor Joined: 27 May 2005 Posts: 71 Location: London
Bizman wrote:
tfu wrote:
I have successfully installed a Samsung HD204UI Spinpoint F4 2TB SATA hard drive and Startech IDE to SATA drive mounted adaptor in my Toppy TF5810PVRt...... and have had no problems.
It may take a week or so before any show up, especially with 2TB. Best of luck, keep us posted. Smile

It's been in since 7th July, though admittedly I've been busy, so it's been used mostly for recording.
View user's profile Send private message
fofp
Posted: Sun Dec 02, 2012 5:56 pm Reply with quote
Regular contributor Joined: 16 Mar 2009 Posts: 84
DefineByte wrote:
Well, sometimes certain chips don't like certain drives right? Or is it more the mobo they don't like? Anyway, I guess I'll find out.


The combination definitely matters. I've had a lot of trouble as noted in

http://forum.toppy.org.uk/forum/viewtopic.php?t=19792&postdays=0&postorder=asc&start=0

This thread put me onto the root cause.

Basically I needed to replace a flaky drive in a Toppy 5810. I checked the "working list of IDE/SATA adapters and drives and opted for:

http://www.ebay.co.uk/itm/Avtech-SATA-IDE-PATA-Hard-Drive-Converter-HDDCONV-/130704270032?_trksid=p2047675.m1850&_trkparms=aid%3D222002%26algo%3DSIC.FIT%26ao%3D1%26asc%3D11%26meid%3D2946822044464356533%26pid%3D100011%26prg%3D1005%26rk%3D2%26sd%3D130604010164%26

with the Samsung Ecogreen 1.5Tb HD154UI drive and this cable:

http://www.ebay.co.uk/itm/10-inch-Ultra-ATA-33-100-133-IDE-40-Pin-80-Wire-Black-Round-Cable-FI-R10K-/280752627226?pt=US_Drive_Cables_dapters&hash=item415e291e1a

I got the basic Toppy working, but when I tried to load MyStuff, or other TAPs , I got a verify files and folders then a crash at the point of TAP loading and this would loop unless I hit the zero key to load as a basic Toppy. It also reduced the recording size and the recordings played as if there was interference, or stopped early.
m t
Bothe the avtech adapter and a Maplin one that I bought had the JM20330 chipset. From this and another thread here, I suspected this as a cause and bought the Turbosat adapter.

Eveything now works fine and so the combination does clearly matter.

Cheers

Mike

_________________
50mm case fan mod + 2Tb WD20EZRX SATA drive & Turbosat Adapter.TF5810, TS On, F/W: MS6 Recommended F/W 12/9/2009 +PsZ
TAPs: PruneEPG 1.0; SecCache (UK) v0.4; Extend v1.7; Font Manager 1.0d; EIT Sub (Game) v0.6; EPG2MEI v0.96; MHEG On/Off A3; MyInfo B5.6; Skip 1.34a (TF5800PVR); MyStuff 6.6; fsSave 1.1;
Sig generated by MyInfo on 26/1/18
?
View user's profile Send private message
tfu
Posted: Wed Dec 05, 2012 1:17 am Reply with quote
Regular contributor Joined: 27 May 2005 Posts: 71 Location: London
tfu wrote:
Bizman wrote:
tfu wrote:
I have successfully installed a Samsung HD204UI Spinpoint F4 2TB SATA hard drive and Startech IDE to SATA drive mounted adaptor in my Toppy TF5810PVRt...... and have had no problems.
It may take a week or so before any show up, especially with 2TB. Best of luck, keep us posted. Smile

It's been in since 7th July, though admittedly I've been busy, so it's been used mostly for recording.

Tempting fate I know, but after 5 months, it hasn't missed a beat.
View user's profile Send private message
Bizman
Posted: Wed Dec 05, 2012 10:21 am Reply with quote
Frequent contributor Joined: 06 Apr 2010 Posts: 1707
Sounds good to me. Smile

_________________
TF5810, F/W: 5.15.09T 4/9/2009 -FmTe+EzHsVb
TAPs: EIT Sub (Game) v0.6; SecCache (UK) v0.4; MHEG On/Off A3; MPDisplayLITE V1.2; MyInfo B5.6; PruneEPG 1.0; EPG2MEI v0.96; QuickJump 1.72; Extend v1.7; (fsSave 1.1);
Sig generated by MyInfo on 3/8/17

Other TAPs : FsCheck, Channel Organiser. PSU Caps 7/2/2011 Tx: Mendip. TV: Samsung (32"), NSLU2, STB: Labgear FV300. PC Acer Aspire One with Win7 Starter
View user's profile Send private message
langdt
Posted: Sat Apr 27, 2013 2:21 pm Reply with quote
Regular contributor Joined: 14 Apr 2006 Posts: 26 Location: London
I haven't seen anyone else mentioning one of these adapters SODIAL(TM) SATA to PATA/IDE Hard Drive Interface Adapter but it was cheap so I gave it a try with a WD10EZRX. Messed around with jumpers and 80 way IDE cable but the Toppy just didn't see the drive.

The IDE cable was about 2" long from a disk enclosure but I'm assuming that won't make a difference.

Going to order the Turbosat adapter and have another try next weekend.
View user's profile Send private message
denbigh1974
Posted: Tue Jul 02, 2013 12:10 pm Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
andyfras wrote:
I have used the combination of WD10EARS and Lycom ST-1062 on several Toppies, so something else must be the problem. I suggest trying the 80 wire ribbon in place of the round IDE, as that's what I've always used.


Can someone please help me specify the IDE cable that is mentioned in various posts on this thread?

An 80-wire ribbon cable is mentioned. Why '80' if the IDE connector at either end only has 40 pins?

I have pulled an IDE cable off an old motherboard. It has 40 wires and looks identical at either end (although I have marked the end that came out of the motherboard).

The connector at both ends looks like this:



I can't see any obvious polarity in my cable. Is it suitable? Why is there an instruction on this thread to put the motherboard end of the cable in the PATA/SATA adaptor if the cable has no polarity?

Apologies if these are dumb questions.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message
Iken
Posted: Tue Jul 02, 2013 4:58 pm Reply with quote
Frequent contributor Joined: 13 Jul 2006 Posts: 109 Location: Hertfordshire, Sandy Heath Tx
denbigh1974 wrote:

Apologies if these are dumb questions.


No such thing!

I understand your confusion. The connectors on both 40- and 80-wire are identical. The difference is the thickness of the strands and the number; each of the 40 pins gains a second wire connection to ground, improving data flow. They essentially reduce crosstalk by 'absorbing' stray signals at the higher transfer speeds of the 'old' Ultra-DMA specs.
This is why they are recommended for the Toppy when using SATA.

Your second point relates to the SATA adaptor being the 'motherboard' and the Toppy board being the 'device' in this case.
This is why it can be necessary to remove/drill out the blank at the end(s) of the cable - all 40 connections are required.

Hope that helps!

_________________
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009 -R+BmC0DsEvIMPeR0UUuUyVyZ
Autorun TAPs: Power Restore V0.7.8; MHEG Control B2.1; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Extend v1.7; Font Manager 1.0d; TF5000 Display v1.53; MyStuff 6.5; MyInfo B5.6.
Manual TAPs: ChannelOrganiser B2X10; FwLoad B3.3; HDD Info V2.4d; SignalMonitor 0.54; TAP Commander 1.34.

Last Updated 21/10/2013
?
View user's profile Send private message
denbigh1974
Posted: Tue Jul 02, 2013 6:20 pm Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
Iken wrote:
denbigh1974 wrote:

Apologies if these are dumb questions.


No such thing!

I understand your confusion. The connectors on both 40- and 80-wire are identical. The difference is the thickness of the strands and the number; each of the 40 pins gains a second wire connection to ground, improving data flow. They essentially reduce crosstalk by 'absorbing' stray signals at the higher transfer speeds of the 'old' Ultra-DMA specs.
This is why they are recommended for the Toppy when using SATA.

Your second point relates to the SATA adaptor being the 'motherboard' and the Toppy board being the 'device' in this case.
This is why it can be necessary to remove/drill out the blank at the end(s) of the cable - all 40 connections are required.

Hope that helps!


It does help - that's an excellent explanation, thank you!

Well I'm blowed, I never knew that there were two types of IDE cables. Now I realise that I'm going to have to buy a new cable rather than plunder one from my old p.c.

I think that you just saved me from a lot of frustration. Very Happy

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message
Iken
Posted: Tue Jul 02, 2013 6:53 pm Reply with quote
Frequent contributor Joined: 13 Jul 2006 Posts: 109 Location: Hertfordshire, Sandy Heath Tx
Very glad to help Very Happy

Good luck with your upgrade.

Oh, and don't forget the upgrade to MyStuff 6.5 either Wink

_________________
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009 -R+BmC0DsEvIMPeR0UUuUyVyZ
Autorun TAPs: Power Restore V0.7.8; MHEG Control B2.1; EIT Sub (Game) v0.6; SecCache (UK) v0.4; EPG2MEI v0.96; Extend v1.7; Font Manager 1.0d; TF5000 Display v1.53; MyStuff 6.5; MyInfo B5.6.
Manual TAPs: ChannelOrganiser B2X10; FwLoad B3.3; HDD Info V2.4d; SignalMonitor 0.54; TAP Commander 1.34.

Last Updated 21/10/2013
?
View user's profile Send private message
denbigh1974
Posted: Tue Jul 02, 2013 7:29 pm Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
denbigh1974 wrote:
I never knew that there were two types of IDE cables.


Corollary question arising from this new found knowledge:

For p.c.s, the 80-conductor cable is connected as follows:
Blue--->motherboard
Black--->master HDD

For the TF5800, my understanding is that the 80-conductor cable is connected as follows:
Blue--->PATA/SATA adaptor
Black--->Main Toppy pcb

The existing cable inside a TF5800 is about 11cm long including the connectors. It has a ferrite around the wires. This cable will be too short once the PATA/SATA adaptor is fitted.

In your experience, what is the optimum replacement cable length and do I need to get a clip-on ferrite to go round it?

30cm seems to be the shortest 80-conductor cable that is available from Maplins. There's a 14cm cable on Ebay http://www.ebay.co.uk/itm/Short-IDE-Ribbon-Cable-Approx-14cms-Length-40-pin-80-wire-/221211715572?pt=UK_Computing_Drive_Cables_Adapters&hash=item33813ee7f4

Edit: Having looked inside the TF5800, the minimum ATA cable length needed is around 20cm

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message
andyfras
Posted: Tue Jul 02, 2013 8:06 pm Reply with quote
Frequent contributor Joined: 25 Jul 2005 Posts: 3450
This is what I use:

http://www.ebay.co.uk/itm/390478542720

Just cut off the superfluous end with a very sharp knife.

You might still get the BOGOF deal.

The surplus is taken out over the mainboard, doubled back on itself, then a 45 fold provides the right-angle to the adapter.

_________________
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
View user's profile Send private message Visit poster's website
denbigh1974
Posted: Tue Jul 02, 2013 9:25 pm Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
andyfras wrote:
This is what I use:

http://www.ebay.co.uk/itm/390478542720

Just cut off the superfluous end with a very sharp knife.

You might still get the BOGOF deal.

The surplus is taken out over the mainboard, doubled back on itself, then a 45 fold provides the right-angle to the adapter.


Thanks, Andy, I've just ordered one.

When you say 'cut off the superfluous end' do you mean cut off the black connector so that only the blue and grey ones are left?

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message
andyfras
Posted: Tue Jul 02, 2013 9:45 pm Reply with quote
Frequent contributor Joined: 25 Jul 2005 Posts: 3450
denbigh1974 wrote:
When you say 'cut off the superfluous end' do you mean cut off the black connector so that only the blue and grey ones are left?

Yes.

_________________
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.6 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver : Prune EPG
Channel Organiser : Tap Commander : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 320GB 2.5", Recommended_5800.tfd + CfPePsScUUuWfZ
View user's profile Send private message Visit poster's website
denbigh1974
Posted: Fri Jul 05, 2013 11:20 am Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
andyfras wrote:
This is what I use:

http://www.ebay.co.uk/itm/390478542720

Just cut off the superfluous end with a very sharp knife.

You might still get the BOGOF deal.

The surplus is taken out over the mainboard, doubled back on itself, then a 45 fold provides the right-angle to the adapter.


"You might still get the BOGOF deal."... I did receive an extra ribbon cable so if anybody wants a freebie I'm happy to post it to them if they want to get in touch

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message
denbigh1974
Posted: Fri Jul 05, 2013 12:39 pm Reply with quote
Regular contributor Joined: 21 Jan 2010 Posts: 25
andyfras wrote:
This is what I use:

http://www.ebay.co.uk/itm/390478542720

Just cut off the superfluous end with a very sharp knife.

You might still get the BOGOF deal.

The surplus is taken out over the mainboard, doubled back on itself, then a 45 fold provides the right-angle to the adapter.


In my TF5800 I have just installed:
(a) Andy's cable recommendation quoted above, with the black IDE connector end removed
(b) WesternDigital 1TB WD10EZRX SATA drive from Scan Computers http://www.scan.co.uk/products/1tb-wd-wd10ezrx-caviar-green-35-hdd-sata-iii-6gb-s-intellipower-64mb-cache-8ms-oem
(c) StarTech IDE-to-SATA Adaptor Converter http://www.kikatek.com/P73288/IDE2SAT-StarTech-2-5in-and-3-5in-40-Pin-Male-IDE-to (via Amazon)

Concerning the cable, once I had removed the black connector end, the overall length was about 12 inches. I checked that, where I had cut the cable at the grey connector, there were no shorts between any of the 80 wires.

I used a soldering iron to melt a tiny hole in the pin 20 blanking position on the grey IDE connector. I cut away any excess melted plastic with a scalpel. Probably not the most professional approach but I didn't have a small hand drill.

I put a jumper link between pins 5 and 6 on the WD10EZRX as shown here: http://wdc.custhelp.com/app/answers/detail/search/1/a_id/1679#jumper As noted elsewhere, this limits the data transfer speed to 3Gb/s.

I left the link on the IDE-to-SATA adaptor in the 'MASTER' position. Make sure the blue cable connector is fully inserted into the adaptor header (i.e. the pins on the header should not be visible). Connect the 4-pin male power connector on the adaptor to the equivalent female socket on the flying lead attached to the TF5800 main board.

On powering up the TF5800, I was asked if I wanted to format the drive, which I did. It took less than a minute.

Tried a few test recordings which seem to work fine.

Everything seems to be working OK after 24 hours.

Will post back if any problems encountered over the next couple of weeks.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; MyStuff 6.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; PcControl B1.3; EIT Sub (Game) v0.6; MyInfo B5.6;
Sig generated by MyInfo on 5/7/13
?
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 16 of 18
Goto page Previous  1, 2, 3 ... 15, 16, 17, 18  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum