Click here to go to the forum index Click here for the home page
 
Author Message

<  Computer connections  ~  SLUG ftp error - 550 failed to connect to Topfield PVR

Page 1 of 4
Goto page 1, 2, 3, 4  Next
leehaynes
Posted: Fri Sep 22, 2006 10:16 pm Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
Hope someone can help!

I've been tearing my hair out trying to get the sulg set up, ftpd-topfield installed, now trying to ftp to the toppy through filezilla.

I'm getting the message 550 failed to connect to Topfield PVR.

I'm using username: anonymous blank password.

I presume something is being seen as "topfield PVR" is mentioned in the error?

It's probably something really simple but i just cant seem to get in there!

cheers

Lee
View user's profile Send private message MSN Messenger
vroomfondle
Posted: Fri Sep 22, 2006 10:49 pm Reply with quote
Frequent contributor Joined: 09 Jun 2005 Posts: 1338 Location: TX: Hannington
In source code:
Code:
reply(550, "Failed to connect to Topfield PVR");

So this does not mean it can see the Toppy.
Obviously Toppy must be on and connected to usb port.

puppy is another util you can try
e.g. puppy -c dir should give you a top level listing of Toppy's files.
If that doesn't work then prob connection problems.
If it does work ftpd may be problem.
Did you get it from here? http://members.ozemail.com.au/~msteveb/topfield/
What options have you got on ftpd-topfield ?

_________________
5800 (400Gb, fan cooled). Firmware: 5.13.40PHT2a Taps: MyStuff5.21a, Mediamanager1.3
Other: ASUS WL-500gx + Olegs (1.9.2.7-7f) + ftpd-topfield (0.7.4) + rt2mei0.63
View user's profile Send private message
Qwakrz
Posted: Sat Sep 23, 2006 12:09 am Reply with quote
Frequent contributor Joined: 17 Apr 2006 Posts: 189 Location: Plymouth, UK
Also, may not be connected but worth a check.

Disable FTP in the slug's web menu as that is for accessing any HDD's attached via the USB ports, if its enabled and you have the toppy connected you will not get a connection to the toppy via FTP because it gets blocked by the slug's built in FTP.

_________________
Toppy 5800 320GB (x 160GB) with 95-99% sig strength 99% Q

Taps: (TAPCommander), RemoteExtender, DescriptionExtender, MyStuff, TF5000 display and eit2mei.
View user's profile Send private message
leehaynes
Posted: Sat Sep 23, 2006 10:36 am Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
Just thought i'd say that i'm a total novice when it comes to telnet. and never even used it before until now Confused
I've tried using teraterm with no joy, but managed to install ftpd-topfield using start/run.../telnet 192.168.x.x and then following the instructions as per the pdf user guide.

Since then i've tried re-installing ftp-d topfield just incase something was wrong there. It told me that there was nothing to be done as it was already up to date. Which was a positive thing.

So, i've been having a dabble, checking all settings within the slug setup and everything looks ok.

I thought i'd try to see if i could connect to a usb pendrive plugged into port 2 on the slug. So shut slug down - inserted pen drive - rebooted - waited until ready, and i can't get the pen drive to show - should it show up as a disk as if i had plugged it directly into the PC?

Also, i tried to find where to disable ftp on the slug and couldn't find any reference to it anywhere.

I think this will be quite a slow process for me and will probably need step by step help from someone to be able to get up and running!

Hope someone with a bit of patience can help.
View user's profile Send private message MSN Messenger
nwhitfield
Posted: Sat Sep 23, 2006 10:45 am Reply with quote
Site Admin Joined: 20 Mar 2005 Posts: 9579
If you're seeing the message 'Cannot connect to Topfield PVR' then your FTP program is connecting to ftpd-topfield, and the message means exactly what it says - ftpd-topfield cannot connect to the PVR.

The USB cable could be unplugged, the Toppy turned off, or there's some other USB fault.

The problem is not anything to do with another ftp server on the Slug; it's communication between PVR and Slug.

Nigel.

_________________
Support this site - make a donation to our running costs
View user's profile Send private message Visit poster's website
leehaynes
Posted: Sat Sep 23, 2006 11:10 am Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
just tried testing out my usb cable with direct connection between the toppy and pc using altair and the connection was fine.

Now i'm getting even more baffled as the cable seems to be ok. Confused
View user's profile Send private message MSN Messenger
vroomfondle
Posted: Sat Sep 23, 2006 1:14 pm Reply with quote
Frequent contributor Joined: 09 Jun 2005 Posts: 1338 Location: TX: Hannington
leehaynes wrote:

Now i'm getting even more baffled as the cable seems to be ok. Confused

yes but is the slug's usb port ok?
if you can do
Code:
ipkg install libusb

then, with Toppy connected
Code:
testlibusb

It will be quite clear if it sees a Toppy
eg on my Asus
Code:
# testlibusb
Dev #1: Linux 2.4.20 ehci_hcd - PCI device 1106:3104
  Dev #9: Topfield Co., Ltd. - Topfield (http://www.topfield.co.kr)
  Dev #3: SanDisk Corp. - Cruzer Micro
Dev #1: 0000 - USB UHCI Root Hub
Dev #1: 0000 - USB UHCI Root Hub

_________________
5800 (400Gb, fan cooled). Firmware: 5.13.40PHT2a Taps: MyStuff5.21a, Mediamanager1.3
Other: ASUS WL-500gx + Olegs (1.9.2.7-7f) + ftpd-topfield (0.7.4) + rt2mei0.63
View user's profile Send private message
leehaynes
Posted: Sat Sep 23, 2006 1:38 pm Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
thanks for that.

tried ipkg install libusb - success, downloaded and installed.

I then plugged in the toppy and rebooted the slug.

then, enabled telnet again, logged in, then at prompt.. testlibusb - i got this reply: testlibusb: No such file or directory.
View user's profile Send private message MSN Messenger
vroomfondle
Posted: Sat Sep 23, 2006 6:54 pm Reply with quote
Frequent contributor Joined: 09 Jun 2005 Posts: 1338 Location: TX: Hannington
its not in your path. search for it
e.g. look in /opt/lib

_________________
5800 (400Gb, fan cooled). Firmware: 5.13.40PHT2a Taps: MyStuff5.21a, Mediamanager1.3
Other: ASUS WL-500gx + Olegs (1.9.2.7-7f) + ftpd-topfield (0.7.4) + rt2mei0.63
View user's profile Send private message
leehaynes
Posted: Sat Sep 23, 2006 7:11 pm Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
typed - /opt/lib

result - permission denied
View user's profile Send private message MSN Messenger
vroomfondle
Posted: Sat Sep 23, 2006 10:13 pm Reply with quote
Frequent contributor Joined: 09 Jun 2005 Posts: 1338 Location: TX: Hannington
No, look in, as in thats a folder
Code:
ls /opt/lib
ls /opt/bin

Most likely in /opt/bin
so
Code:
/opt/bin/testlibusb

_________________
5800 (400Gb, fan cooled). Firmware: 5.13.40PHT2a Taps: MyStuff5.21a, Mediamanager1.3
Other: ASUS WL-500gx + Olegs (1.9.2.7-7f) + ftpd-topfield (0.7.4) + rt2mei0.63
View user's profile Send private message
h4yn0nnym0u5e
Posted: Sat Sep 23, 2006 11:15 pm Reply with quote
Regular contributor Joined: 27 Sep 2005 Posts: 54 Location: St Neots, UK
Couple of possibly helpful thoughts...

My Slug is quite picky about how it's started and connected to the Toppy - if I do it wrong I seem to recall that's the error I get. My preferred sequence is:
* Unplug Slug/Toppy USB
* Re-boot Slug
* Put Toppy into standby
* Re-plug USB
* Bring Toppy out of standby

Also, is a blank password right for ftpd-topfield? IIRC it'll accept anything except a blank password!

Cheers

Jonathan

_________________
TF5800PVR - 5.13.65 NITfix - TAPs: UK Timers; - 9km from Sandy Heath - NSLU2 - Samsung HD400LD - 6 new EEUFM1C102 caps fitted 3/11/09
View user's profile Send private message
leehaynes
Posted: Sat Sep 23, 2006 11:50 pm Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
thanks vroom for telling me what to type.

this is what i got from /opt/bin/testlibusb

Dev 1: Linux 2.4.22-xfs ehci_hcd - NEC Corporation USB 2.0

and thats it. No mention of the toppy at all.


Also, thanks for the suggestion Jonathan but just tried that sequence but there's still no difference - still the same error message when trying to connect with filezilla.
View user's profile Send private message MSN Messenger
vroomfondle
Posted: Sun Sep 24, 2006 12:29 am Reply with quote
Frequent contributor Joined: 09 Jun 2005 Posts: 1338 Location: TX: Hannington
It appears the Linux running on the slug sees some basic usb hub but no ports

_________________
5800 (400Gb, fan cooled). Firmware: 5.13.40PHT2a Taps: MyStuff5.21a, Mediamanager1.3
Other: ASUS WL-500gx + Olegs (1.9.2.7-7f) + ftpd-topfield (0.7.4) + rt2mei0.63
View user's profile Send private message
leehaynes
Posted: Sun Sep 24, 2006 8:59 pm Reply with quote
Regular contributor Joined: 25 Nov 2005 Posts: 81 Location: Bromsgrove, Worcs
i decided to start from scratch, just incase i had done something wrong in the first place.

I first reflashed the slug so it was back to original firmware.

I then followed the instructions in Malcs PDF really carefully, this time using unslung 4.2 and ftpd-topfield 0.6.6-1 by rafe's method.

All went smoothly, no errors at all. Good news...

...or so i thought.

Loaded up filezilla, input the ip address, and this is what it gave me:

Status: Connecting to 192.168.1.78 ...
Status: Connected with 192.168.1.78. Waiting for welcome message...
Response: 550 Failed to connect to Topfield PVR
Command: USER anonymous
Error: Disconnected from server
Error: Unable to connect!


So after spending a couple of hours starting from scratch, i'm back to exactly the same place yesterday.

Crying or Very sad
View user's profile Send private message MSN Messenger

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 4
Goto page 1, 2, 3, 4  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum