Click here to go to the forum index Click here for the home page
 
Author Message

<  Bugs  ~  Lock up during play and record and component

Page 1 of 1
mp_york
Posted: Wed Aug 21, 2019 9:23 am Reply with quote
Regular contributor Joined: 09 Jul 2007 Posts: 30
Our second Toppy has been playing up for quite a while now. It has a couple of issues, but as it is only used when there are 3 overlapping things to record, it is only a minor annoyance.

1) Lock up during play and record, after various durations. Sometimes it works fine for over an hour's viewing, but other times locks up within 20 minutes, either viewing or recording. It doesn't seem to get overly warm. And the TV signal is fine because it goes through all the devices to the TV. It is more unreliable doing both play and record simultaneously, making me think it's something to do with the HDD connection. To recover it is necessary to power off then on. And it often requires multiple remote power presses, before any thing happens and even then might take over 30 seconds before the return to standby. On power on it then does a verifying files and folder and then everything seems OK, until the next lock up.

2) This is the Toppy connected to the TV by component (SCART to 5 RCA plugs), which regularly causes the Panasonic TV to switch off, normally on the black screen prior to the credits at the end of a programme. In fact further research has found it puts the TV into an error condition, with a red warning LED flashing. See my original post https://forum.toppy.org.uk/forum/viewtopic.php?t=21253. It has been happily running with component for over 3 years, before this problem started.

I'm not sure if the issues are related.

This Toppy has the firmware patch to use the 5810 remote codes, so I can control both with a Universal remote.

I've done some investigation, without resolution. I did the full capacitor replacement (using one of Andy's kit) on the PSU in about 2016. And just re-checked the voltages, which generally look OK:

Marked Measured
30V 30.5
22V 24.6
17V 17.21
8V 7.47
5V 5.06
3.3V 3.32
15V 15.7
12V 12.39

I upgraded the HDDs in both Toppy's a number of years ago both with SATA 1TB Samsung HDDs. I had a spare PATA to SATA (Startech) adapter and 80 pin ribbon cable, so tried recently tried swapping these, which initially looked promising, but no, the lock up is still happening.

Any suggestions?

I do have some other old HDDs that I could try and I haven't looked at MyInfo or run fsCheck yet. I have another couple of Toppy's in various states of destruction, so between them there maybe enough parts to make a fully working one. As an ageing software engineer, I find messing with this stuff an interesting challenge. I scare myself every time a pick up a soldering iron - but I've successfully replaced the capacitors on a number of the PSUs now.

Thanks,
mp_york.

_________________
2xTF5800 1TB Black. TAPs: MyStuff.
View user's profile Send private message
ccs
Posted: Wed Aug 21, 2019 10:15 am Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2582
I think posting a Myinfo log would be a good start.

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
jimi
Posted: Wed Aug 21, 2019 11:01 am Reply with quote
Frequent contributor Joined: 29 Mar 2006 Posts: 168
Regarding the TV problem, swap the 2 toppy connections over and see if the problem moves with the toppy.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+Pe
TAPs: PcControl B1.4; Extend v1.7; EPG2MEI v0.96; SecCache (UK) v0.4; EIT Sub (Game) v0.6; Font Manager 1.0d; MHEG On/Off A3; (MyInfo B5.6); PruneEPG 1.0; MyStuff 6.6;
Sig generated by TopManager/PcControl on 01/05/18
View user's profile Send private message Visit poster's website 5800

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 1

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum