Click here to go to the forum index Click here for the home page
 
Author Message

<  MyStuff  ~  MyStuff 4.54

Page 108 of 157
Goto page Previous  1, 2, 3 ... 107, 108, 109 ... 155, 156, 157  Next
BobD
Posted: Mon Nov 06, 2006 2:14 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4195 Location: Nottingham
cuthbert wrote:
Had my Topfield 2 weeks now, and just installed MyStuff 4.54e. I thought the original UI was pretty good until I saw this! Cool. Control timers are a killer feature, and really release the power of the box. There are many smaller features I like too, particularly the way you can resume viewing your last viewed recording by pressing the slow key. And the way MyStuff deals with padding and back to back recordings is very slick. Well done to Bob and the team, I say.

Thanks for that Smile

Quote:
I guess this has been mentioned before, though I could not find it with a search: If you create your 'My Favourites.mcl' file on a Linux box, don't forget to convert it to Dos/Windows text, otherwise you will see some very odd behaviour in the EPG. I am running Linux and using puppy for transfers. I coverted this piece of perl: s/\n/\r\n/;
Yup its an old problem that I may get round to fixing one day (if I haven't already!) Actually, email me one of your non-working .mcl files and I'll make sure it works in the next version.

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
BobD
Posted: Mon Nov 06, 2006 2:16 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4195 Location: Nottingham
IanSimmons wrote:
bygjohn wrote:
What happens is, that when a radio timer starts (at least one on Radio 4), the programme shows in the archive with the details for what's currently on Channel 5, presumably as it's a TV channel on the same mux. So, for example, last night's Archers showed as Willy Wonka and the Chocolate Factory, which is pleasingly surreal, I'll admit Laughing


I think it's been mentioned before... Similarly, I copied a small section out of the Eurovision Song Contest (the hilarious Finnish winning entry Twisted Evil ) so I could delete the main file. MS reported the resulting file as 'News Today' or something similar, which happened to be on at the time I made the copy. The Toppy archive reported it correctly as a Eurovision copy.

Didn't know about that one (unless I did, and have already fixed it!) ACtually, it does ring a bit of a bell! I will check to see what the next version does for radio recordings, and make sure it works.

Cheers

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
bygjohn
Posted: Mon Nov 06, 2006 3:11 pm Reply with quote
Frequent contributor Joined: 30 May 2006 Posts: 216 Location: Crewe (TX: Winter Hill)
Thanks.

And thanks for a great TAP, by the way: the more I play with it, the more I like it. Especially the bits which make automatic the things which should really have been all along. An example being the way it automatically renames files if necessary when moving them into folders, which I discovered last night. And the cross-channel padding handling.

_________________
Toppy: TF5800PVR/250 Firmware: 5.13.65 Hardware: 1.00
Autostart TAPs: RemoteExtenderMHEG 1.4, running_status_fix 0.01, DescriptionExtender 2.1, eit2mei 7.8, MyStuff 5.21a
Other TAPs: TAPCommander 1.01, ChannelRemover 1.4, HDD Info 2.0
View user's profile Send private message
mike.hinson
Posted: Mon Nov 06, 2006 5:28 pm Reply with quote
Frequent contributor Joined: 18 Nov 2005 Posts: 1735 Location: Bordon, Hants UK
Repeated crash in MS archive view

Hi,
I was just looking at my Toppy archive view & it rebooted, when it came back it did a "verifying files" and seemed ok.

I could reproduce this crash by going into the MS archive view (sorted by date) and scrolling down the list. When I got to about file 48 of about 60 it crashed.

It also crashed if I scrolled up from the top to take me to the bottom of the list.

It also crashed if I used the >> key to page down a few pages.

I moved the most recent files into a subdirectory -- still crashed
I moved about 10 episodes of Scrubs into a sub dir -- still crashed
I moved 4 of the oldest files into a subdir -- no crash
I navigated into the oldest files subdir -- no crash
I moved the files back out of the subdir (in native mode) -- still no crash

Is there any more diagnostics I can do?
This sounds similar to the crashes Bob was investigating with Juwlz

The only thing I was wondering was that perhaps viewing the oldest files subdir with MS changed something??

I am keen to help gather more info if it will help.
& thanks as always for the best TAP is the universe Very Happy

TapComander reports I have 17.4M of free memory

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; Standby v1.8; SecCache (UK) v0.4; QuickJump 1.72; MyStuff 6.5; mei2archive BETA 3.8l7; Extend v1.7; MyInfo B5.6; EIT Sub (Game) v0.6; Font Manager 1.0d; MHEG On/Off A3;
Sig generated by MyInfo on 10/11/13
View user's profile Send private message
juwlz
Posted: Mon Nov 06, 2006 6:12 pm Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10373 Location: Wokingham, Berkshire (Hannington transmitter)
mike.hinson wrote:
Repeated crash in MS archive view

I moved the most recent files into a subdirectory -- still crashed
I moved about 10 episodes of Scrubs into a sub dir -- still crashed
I moved 4 of the oldest files into a subdir -- no crash
I navigated into the oldest files subdir -- no crash
I moved the files back out of the subdir (in native mode) -- still no crash

Is there any more diagnostics I can do?
This sounds similar to the crashes Bob was investigating with Juwlz

I am keen to help gather more info if it will help.
Hi Mike

The only thing we seem to have established so far is that once you make the problem go away, you can't get it to come back again Shocked

So, if you (or anyone else) sees the problem again, please
1. back up your MEI directory (in ProgramFiles) and
2. contact BobD for a diagnostic version of MyStuff which will put messages on the screen about what's happening INSTEAD of moving files around to see what makes it go away.

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
mike.hinson
Posted: Mon Nov 06, 2006 6:28 pm Reply with quote
Frequent contributor Joined: 18 Nov 2005 Posts: 1735 Location: Bordon, Hants UK
juwlz wrote:
The only thing we seem to have established so far is that once you make the problem go away, you can't get it to come back again Shocked

So, if you (or anyone else) sees the problem again, please
1. back up your MEI directory (in ProgramFiles) and
2. contact BobD for a diagnostic version of MyStuff which will put messages on the screen about what's happening INSTEAD of moving files around to see what makes it go away.

Julie
Oh Sorry Embarassed
Looks like I rushed in too quick & lost us an opportunity. Crying or Very sad

I was just so keen to try and discover what was going on.

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; Standby v1.8; SecCache (UK) v0.4; QuickJump 1.72; MyStuff 6.5; mei2archive BETA 3.8l7; Extend v1.7; MyInfo B5.6; EIT Sub (Game) v0.6; Font Manager 1.0d; MHEG On/Off A3;
Sig generated by MyInfo on 10/11/13
View user's profile Send private message
BobD
Posted: Mon Nov 06, 2006 6:55 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4195 Location: Nottingham
Hi Mike

Oh well, keep an eye on this and if you can make it do it again then please do as juwlz says, and let me know (by posting here, by PM or by email) and then we can try to debug it. I am really keen to work out what is going on here, since it does seem to keep happening!

Cheers

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
mike.hinson
Posted: Mon Nov 06, 2006 11:43 pm Reply with quote
Frequent contributor Joined: 18 Nov 2005 Posts: 1735 Location: Bordon, Hants UK
BobD wrote:
Hi Mike

Oh well, keep an eye on this and if you can make it do it again then please do as juwlz says, and let me know (by posting here, by PM or by email) and then we can try to debug it. I am really keen to work out what is going on here, since it does seem to keep happening!

Cheers
Hi guys,
I have been trying to get MS to crash again for over an hour. Evil or Very Mad Twisted Evil
I have been moving files, deleting stuff, creating directories, setting up new timers & CTs & deleting them again, turning them on & off and I have not had anything even slightly odd happen.

MS seems very robust and well behaved 99.99% of the time. I am very impressed with the quality of support available from everyone here, THANKS Very Happy

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
TAPs: EPG2MEI v0.96; Standby v1.8; SecCache (UK) v0.4; QuickJump 1.72; MyStuff 6.5; mei2archive BETA 3.8l7; Extend v1.7; MyInfo B5.6; EIT Sub (Game) v0.6; Font Manager 1.0d; MHEG On/Off A3;
Sig generated by MyInfo on 10/11/13
View user's profile Send private message
digital
Posted: Mon Nov 06, 2006 11:52 pm Reply with quote
Frequent contributor Joined: 30 Jun 2005 Posts: 360
Derham wrote:
digital wrote:
I moved all TAPs except Tap Commander, MyStuff and eit2mei out of AutoStart and went into and out of standby but 'Unable to get memory to load EPG data!' displayed again with memory back down to 1.4MB overnight.

Into standby and out again brings it up to 17.8MB.

Anyone any ideas on what to do next with only the above three TAPs loaded in AutoStart?

I assume TAP Commander is unlikely to be the cause of a memory leak.


Try deleting the Freeview.mei file that eit2mei creates and let it build it again. I've had that problem and deleting the file has corrected it.

Hmm. Tried that but memory has been draining away all evening with all my usual TAPs installed and then again with only Tap Commander, MyStuff and eit2mei.

Anyone else getting this? Anyone with any more ideas on what might be causing it?

The only change here is that I've left the Toppy on 24/7 recently rather than putting it into standby overnight.

_________________
Frank
TF5800t, IA On, TS On, F/W: MS6 Recommended F/W 12/9/2009 +Pe
TAPs: EPG2MEI v0.96; MyStuff 6.3; Font Manager 1.0d; Extend v1.7; MyInfo B5.5; TAP Commander 1.32; TF5000 Display v1.53; SecCache (UK) v0.4; EIT Sub (Game) v0.6;
Sig generated by MyInfo on 11/4/11
View user's profile Send private message
juwlz
Posted: Tue Nov 07, 2006 10:10 am Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10373 Location: Wokingham, Berkshire (Hannington transmitter)
mike.hinson wrote:
Hi guys,
I have been trying to get MS to crash again for over an hour. Evil or Very Mad Twisted Evil
I have been moving files, deleting stuff, creating directories, setting up new timers & CTs & deleting them again, turning them on & off and I have not had anything even slightly odd happen.
The phrase "I told you so" springs to mind Wink. Can't fault the dedication though.

One other thing occurred to me: as YOUR reboot was from the top-level directory (all the others so far have been on entering a particular directory), one extra thing you might like to do to prevent tempers fraying if you get the same thing again would be to temporarily change the key that MS uses to bring up the archive, so that you don't keep accidentally rebooting. Pressing Archive and getting the native archive is slightly less frustrating that pressing it and getting a reboot Wink

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
juwlz
Posted: Tue Nov 07, 2006 10:29 am Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10373 Location: Wokingham, Berkshire (Hannington transmitter)
digital wrote:
Derham wrote:
Try deleting the Freeview.mei file that eit2mei creates and let it build it again. I've had that problem and deleting the file has corrected it.

Hmm. Tried that but memory has been draining away all evening with all my usual TAPs installed and then again with only Tap Commander, MyStuff and eit2mei.

Anyone else getting this? Anyone with any more ideas on what might be causing it?

The only change here is that I've left the Toppy on 24/7 recently rather than putting it into standby overnight.
Hi digital

Can you spot any pattern to when the memory drains away? Is it when watching live TV? Watching recordings? Recording? Recording AND watching together? Listing upcoming recordings? Viewing the directory? Listing CTs? How fast is it draining away? Does it drop in "regular" chunks, and how often? (e.g. do you lose 0.1Mb every 10 minutes, or 0.5Mb and then nothing for half an hour and then another 0.2?)

Have you got MyStuff's loading and searching notifications on? If not, switch them on and see whether the memory disappears after each one of those? Did you contact DX to see if he could supply a diagnostic version of eit2mei so you can see if memory disappears during / after EPG harvesting?

Try taking TAP Commander and eit2mei out of the equation, and see what happens with just MemWatcher and MyStuff running. Are you stopping TAPs running by disabling them with TAPCommander, or by moving them out of Autostart? If with TAPCommander, it might be worth moving EVERYTHING except MemWatcher out of Autostart to be absolutely sure there can't possibly be anything running that you don't know about, and then starting MyStuff manuall (and nothing else).

My Toppy is always on 24/7, with TAPs and firmware as in signature, and although I HAVE had memory leaks, they seem to be one-off occasionals for me (or maybe just much slower!), not a constant drip-drip like yours, so I guess there must be something about different usage patterns or configuration that's making the difference. (Maybe whatever causes it relates to something you do regularly that I only do once in a while?)

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
DX
Posted: Tue Nov 07, 2006 11:29 am Reply with quote
Frequent contributor Joined: 06 Apr 2005 Posts: 2673
digital wrote:
Hmm. Tried that but memory has been draining away all evening with all my usual TAPs installed and then again with only Tap Commander, MyStuff and eit2mei.

Anyone else getting this? Anyone with any more ideas on what might be causing it?

The only change here is that I've left the Toppy on 24/7 recently rather than putting it into standby overnight.

I've seen similar behaviour on firmware 5.13.26, but not on 5.12.88 (although ISTR Jag's users seeing something like this on .88). On 5.13.26 when I investigated I'm 99% sure it was the firmware leaking memory when taps were active, not the taps themselves leaking.

The most obvious thing to try is to go back to putting your Toppy in standby overnight, since you suspect it is this change in behaviour that started the problem.

Other than that try one or more of the following.

Turn off Interactive Services (the Toppy MHEG engine has form with memory issues). Use an external mei source such as rt2mei. Use eit2mei with scheduled scan only + poweroff. Turn off MyStuff auto loading of EPG. Try a full system reset. Delete everything on ProgramFiles and reinstall - don't be tempted to save existing files/settings but download new copies of everything and set them up from scratch. Try a different firmware - either 5.12.25 or 5.13.26 - and see if either of them work better for you.

Sorry if the above sounds a bit hit-and-miss but I'm afraid you have a rather unusual problem so it's unlikely you'll find an off the shelf solution.
View user's profile Send private message
Baj
Posted: Tue Nov 07, 2006 11:49 am Reply with quote
Joined: 19 Sep 2006 Posts: 13 Location: Canterbury
Hi

I'm new to MS - brilliant TAP, but I have a problem renaming files.

As far as I can tell it is not possible to rename files in MS Archive. So I went into the Toppy archive and renamed a file; but the Ms archive file name did not change. Tried again with a different file and it worked: the MS archive file name had changed. This is the only time that I succeeded; all subsequent attempts to change file names in MS archive failed.

What am I doing wrong? Help please.

Thanks in anticipation

Baj
View user's profile Send private message
juwlz
Posted: Tue Nov 07, 2006 12:17 pm Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10373 Location: Wokingham, Berkshire (Hannington transmitter)
Baj wrote:
Hi

I'm new to MS - brilliant TAP, but I have a problem renaming files.

As far as I can tell it is not possible to rename files in MS Archive. So I went into the Toppy archive and renamed a file; but the Ms archive file name did not change. Tried again with a different file and it worked: the MS archive file name had changed. This is the only time that I succeeded; all subsequent attempts to change file names in MS archive failed.

What am I doing wrong? Help please.

Thanks in anticipation

Baj
Hi Baj, and welcome

The names you see in MyStuff Archive are programme names, not file names. If a MEI file exists for the programme, then MyStuff will display the programme name (and other info) recorded in the file. It only uses the filename if the MEI file has gone missing for some reason.

If it needs to, MyStuff appends dates to filenames when automoving to avoid duplicate file names, but you won't see this change in the MS display. If all you did was add/remove dates when you were renaming some of your files, then the MEI file for the recording will still be linked to the programme name.

If you make a big change to the name, then MS will lose the link to the MEI file and (I think!) then display the filename instead.

HTH
Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
Livy
Posted: Tue Nov 07, 2006 12:52 pm Reply with quote
Frequent contributor Joined: 14 Jul 2006 Posts: 584 Location: Fife, Scotland
dont know if this is a silly question or not, but when CT's are setup will they be quicker to search if i narrow down the date and time, if its something on the same time every week.

as i have a few CT's setup and it sometimes takes a while when doing a search for programmes.
View user's profile Send private message

Display posts from previous:  

All times are GMT
Page 108 of 157
Goto page Previous  1, 2, 3 ... 107, 108, 109 ... 155, 156, 157  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum