Click here to go to the forum index Click here for the home page
 
Author Message

<  General Toppy discussions  ~  An Enigma2 Recording Manager & Toppy Recording Importer

Page 1 of 3
Goto page 1, 2, 3  Next
EMJB
Posted: Wed Mar 08, 2017 7:39 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
For Julwz and anyone else interested:

I have knocked together a Windows application which mimics the OpenVix "List" functions including playing (on the PC), moving, deleting, & recycling recordings, and merged it with an earlier utility to import Toppy recordings. It has the following advantages FOR ME compared with using the OpenVix List function for managing the recordings list:

* Can use it while the TV is in use for family viewing
* Scrolling etc is faster
* Better screen size to viewing distance ratio, allowing more info to be displayed
* Option to sort recordings by name + description, making it easy to identify duplicates
* Easier to use by virtue of Windows features such as mouse wheel control, and pop-up menus
* Better help/user instructions, again made possible due to Windows features
* Includes some personal "WIBNIFs"

Like the "List" function, it ignores all other file types, and moves/deletes all the files associated with one OpenVix recording without any additional user intervention.

As it accesses the PVR hard disc via Samba, it can be used with PVR recordings on any networked or local hard drive. To use it, simply put the ".exe" file in any convenient directory on PC where it can write its ".ini" file, and run it. You will be prompted to enter the path to your recordings and off you go! It ignores all other file types, and moves/deletes all the files associated with one recording without any additional user intervention.

HOWEVER THIS IS EXPERIMENTAL, & COULD WIPE ALL YOUR RECORDINGS OR DO OTHER NASTIES, SO YOU USE IT AT YOUR OWN RISK! (though it has never done so for me - nothing worse than moving to the wrong folder during de-bugging)

At the moment I have no plans to improve this, but would be pleased to be advised of any bugs and will consider requests for additional functionality if is likely to be useful to a significant number of "converts" etc.



Download from here if you wish to give it a try.

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
alan_m
Posted: Wed Mar 08, 2017 8:28 pm Reply with quote
Frequent contributor Joined: 18 Oct 2006 Posts: 3405
http://www.admac.myzen.co.uk/e2_stuff/

First image my network connection from my laptop to the ET1000, samba enabled, Windows 7 Home premium 64 bit

Second image is the error message I get

(Note: my E2 directory is called 'movie' and not 'movies' as in your example text)

I also get the same error message if I substitute EY1000/ for the box's IP number. I get the same error if I enter a valid path/name for a directory on my laptop.

_________________

5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
EMJB
Posted: Wed Mar 08, 2017 8:43 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
@alan_m:

That looks a bit like a file permissions problem - can you open the movie folder with the PC File manager?

I am on Windows 10, but its an old Delphi compiler so would expect it to be OK with Windows 7. Have an old laptop, so will try it on that if I get a chance tomorrow.

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
alan_m
Posted: Wed Mar 08, 2017 8:47 pm Reply with quote
Frequent contributor Joined: 18 Oct 2006 Posts: 3405
EMJB wrote:
@alan_m:

That looks a bit like a file permissions problem - can you open the movie folder with the PC File manager?


Yes - no problems

I also just tested moving a file from the ET10000 to my laptop - again no problems

_________________

5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
EMJB
Posted: Wed Mar 08, 2017 9:15 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
@alan_m

Managed to find time to try it on Windows Vista - no problems. I trust you haven't set up some password protection on your PVR.

Bit of a loss as to what to suggest next.

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
alan_m
Posted: Wed Mar 08, 2017 9:29 pm Reply with quote
Frequent contributor Joined: 18 Oct 2006 Posts: 3405
[quote="EMJB"]@alan_m

Managed to find time to try it on Windows Vista - no problems. I trust you haven't set up some password protection on your PVR.[quote]

No password protection set-up, user = root, password = blank

_________________

5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
ccs
Posted: Wed Mar 08, 2017 10:25 pm Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2355
I get the same error as @alan_m

Windows 10 Pro + Samba, which works fine accessing/viewing/deleting files etc on my ET10K.

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
juwlz
Posted: Thu Mar 09, 2017 3:41 am Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10773 Location: Wokingham, Berkshire (Hannington transmitter)
Thanks EMJB. Our ET8500 will be shipping tomorrow, so we'll hopefully have it to play with at the weekend. Unfortunately, we'll be busy on Sunday, and I suspect that we'll have plenty of other things to set up and play with on Saturday - and obviously not much in the way of recordings to play with to start off with anyway! But I'll give it a try.

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
EMJB
Posted: Thu Mar 09, 2017 10:05 am Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
Found the alan_m's problem - it occurs if the recycle folder is blank as a result of a late change I put in to avoid another possible problem. Will post a fix shortly, but meanwhile just put any rubbish in there (at least one character) and all should be well.

Sorry about that.

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
EMJB
Posted: Thu Mar 09, 2017 10:49 am Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
Testing on my Vista machine has highlighted another problem - early versions of Windows Media Player will not play the ".ts" files. Will look into this a bit further.

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
EMJB
Posted: Thu Mar 09, 2017 1:54 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
Updated version (X2) now available from here if you wish to give it a try. Hopefully this will fix the problem reported by alan_m and ccs, and includes logic to allow you to use a different viewer if your Windows Media Payer doesn't work (or you would just prefer something else). However I have not tried the latter logic as I don't seem to have anything else suitable on my PC.

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
ccs
Posted: Thu Mar 09, 2017 2:02 pm Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2355
I've been using it to convert toppy files. Great to get programme descriptions back!

Would it be possible for it not to need access to ViX at all during this process, as (the way I'm using it) it only seems to need access to the local pc?

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
EMJB
Posted: Thu Mar 09, 2017 2:33 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
ccs wrote:
Would it be possible for it not to need access to ViX at all during this process, as (the way I'm using it) it only seems to need access to the local pc?


Should do what (I think!) you want if you set the recordings path to somewhere on PC rather than on the PVR - e.g. if you create a folder "D:\Something\exToppy_Recs", put the Toppy recordings in "D:\ToppyRecs" and then:

(1) Set the Recordings Home Directory to: "D:\Something\" on the initial screen

(2) When the file etc list opens, "exToppyRecs" should appear as a folder

(3) Right click on that folder, select import, and enter "D:\ToppyRecs\*.rec" when prompted for the source.

It then should then put the translated files into "D:\Something\exToppy_Recs" and not make any effort to contact the PVR. N.B You cannot currently import into the Home Folder (for no very good reason that I can remember).

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message
ccs
Posted: Thu Mar 09, 2017 2:58 pm Reply with quote
Frequent contributor Joined: 30 Oct 2007 Posts: 2355
Cheers, what I found was the converted files ended up in the same directory as the .exe

_________________
TF5810, F/W: MS6 Recommended F/W 12/9/2009 -FmXl+CtEzIScVdZ
TAPs: EIT Sub v0.6; EPG2MEI v0.96; MPDisplayLITE V1.2; MyInfo B5.6; SecCache (UK) v0.4; Extend v1.7; MyStuff 6.6;
Sig generated by MyInfo on 20/10/14
ccsx
View user's profile Send private message
EMJB
Posted: Thu Mar 09, 2017 3:05 pm Reply with quote
Frequent contributor Joined: 08 Jul 2005 Posts: 3620 Location: Maldon Essex
ccs wrote:
Cheers, what I found was the converted files ended up in the same directory as the .exe


Thanks for the feedback. Will have a look at that - went into the right directory on the PVR when I tried it, but perhaps my fix for something else has upset that!

EMJB

_________________
Silver 5800, Board Rev 1.2, MS recomm F/W, Sudbury Tx, varying TAP config
View user's profile Send private message

Display posts from previous:  

All times are GMT + 1 Hour
Page 1 of 3
Goto page 1, 2, 3  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum