Click here to go to the forum index Click here for the home page
 
Author Message

<  MyStuff  ~  Toppy keeps restarting whilst trying to load MyStuff

Page 2 of 3
Goto page Previous  1, 2, 3  Next
BobD
Posted: Thu Jul 12, 2012 7:29 pm Reply with quote
MyStuff Team Joined: 03 Aug 2005 Posts: 4194 Location: Nottingham
A corrupt EPG file is corrupt only in terms of it contains something that MyStuff really doesn't like. It may not be corrupt in any way that any other program can detect. Deleting it by hand is always the safest bet, as that will allow it to be regenerated - hopefully without the problem.

_________________
FW: ChunkyWizard Recommended
TAPs:
MyStuff (always one version ahead of everyone else!), and recommended support TAPS
MyStuff skins, manual and latest version: http://www.BobDsMyStuff.co.uk
Known bugs & forthcoming fixes: http://www.BobDsMyStuff.co.uk/Bugs.shtml
Changes coming in the next version: http://www.BobDsMyStuff.co.uk/NextVersion.shtml
View user's profile Send private message Visit poster's website
lyppy
Posted: Thu Jul 12, 2012 8:02 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Quote:
Deleting it by hand is always the safest bet, as that will allow it to be regenerated - hopefully without the problem.



How do I do this please?

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
juwlz
Posted: Thu Jul 12, 2012 11:16 pm Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10353 Location: Wokingham, Berkshire (Hannington transmitter)
You could use Altair / Antares, but using TopManager to delete it has the same effect as deleting it by hand. Both just delete the file, and it will get regenerated within 30 minutes.

However, since you've already tried that, the next thing to suspect is your MyStuff.dat file. I won't repeat what's been said in the TopManager thread, but it would be more appropriate to continue to troubleshoot in this thread than to take that one completely off topic and make it difficult to follow what you've tried already.

Julie

P.S. Don't put MyStuff back in Auto Start until the problem that's making it crash has been fixed. If you do, you'll keep getting stuck in reboot loops. Each time we try something, start MyStuff manually. Only if that doesn't crash can we assume that we've fixed the problem and move it back. As far as I can tell, we're not there yet!

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
lyppy
Posted: Mon Jul 16, 2012 7:36 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Toppy worked after I did what Geoff suggested. It was the MyStuff.dat file. He has also suggested on the TopManager forum that I do a few more things which I will do when I return home tomorrow. Thank you for your help

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
Geoff Bacon
Posted: Mon Jul 16, 2012 10:02 pm Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3061 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
Just to point out that Juwlz indicated that it was probably the MyStuff.dat; I just gave you instructions of how to replace it using TopManager

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website
lyppy
Posted: Tue Jul 17, 2012 11:48 am Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Quote:
However, since you've already tried that, the next thing to suspect is your MyStuff.dat file



Quote:
Just to point out that Juwlz indicated that it was probably the MyStuff.dat; I just gave you instructions of how to replace it using TopManager

Geoff


Should I be doing something else with the MyStuff.dat file then?

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
Geoff Bacon
Posted: Tue Jul 17, 2012 11:54 am Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3061 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
Not if you think it is working.

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website
lyppy
Posted: Tue Jul 17, 2012 2:46 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
well apart from one reboot today where the Toppy "veryfied files and folders", the MyStuff launched fine so hopefully its sorted.

Thank you

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
lyppy
Posted: Wed Jul 18, 2012 3:52 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Me again unfortunatley!
In the last 30 minutes whilst watching a recording my Toppy has restarted itself again. The only difference is after verifying files it is loading MyStuff ok. So does this mean there's something wrong with the actual Toppy?

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
juwlz
Posted: Wed Jul 18, 2012 4:51 pm Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10353 Location: Wokingham, Berkshire (Hannington transmitter)
There could be a number of reasons:

1. Hardware issue (typically the PSU, which andyfras or MikeyP can repair for a very good price). Even if it has already been done, occasionally some Toppies have "unusual" failures which can still be fixed.

2. Poor / variably poor signal quality. Normally this manifests itself as a full or partial disk wipe due to a nebulous bug in the firmware, but I suppose you could be "lucky" that it's just blatting smaller bits of your drive. If this is the case, the only solution is to fix the signal quality (if you can, by changing aerial and cabling and/or adding boosters/attenuators), or to delete the affected channels.

3. Residual hard drive damage due to a previously failing PSU ... . In this case, you'll need to replace the drive, probably with a new "green" drive plus adapter. Again, andyfras (and possibly MikeyP) can advise on something suitable and would be able to fit for you if you don't fancy doing it yourself. Note that you have to be careful about which drives and adaptors you use in a Toppy. They don't all work.

NB: This is not necessarily a comprehensive list!

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
lyppy
Posted: Wed Jul 18, 2012 5:00 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Thanks for replying - just a thought, sometimes we use the subtitles and on each occasion when the toppy has restarted these are being used. Could this be the problem? I had the PSU's changed by Andy last October.

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
juwlz
Posted: Thu Jul 19, 2012 8:24 am Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10353 Location: Wokingham, Berkshire (Hannington transmitter)
At the risk of repeating myself ...
juwlz wrote:
Even if it has already been done, occasionally some Toppies have "unusual" failures which can still be fixed.
Subtitles MAY be relevant, as IIRC they need MHEG (Interactive Services) on - and MHEG is a bag of worms.

I guess it's possible you're having memory problems, which can manifest themselves in all sorts of unpredicatable ways. Could you please post a current MyInfo log, which will give us some up to date information on your setup.

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
lyppy
Posted: Thu Jul 19, 2012 10:11 am Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Quote:
Could you please post a current MyInfo log, which will give us some up to date information on your setup.



Thank you for replying - MyInfo log as follows -

MyInfo B5.6 Logging settings etc on: 19/7/2012 at 11:07

Waiting for other TAPs to load and settle

Ini file found
Starting to record data 60 seconds from boot

System ID: 458
TV Output: Type = Auto, Video = RGB, RF Channel = 36
Reported firmware version: TF-NPT 5.13.65T dated Oct 10 2009
Base firmware version: 5.13.65

Running TAPS:
Slot 0: EPG2MEI v0.96 : Dumps the EPG data to disk as EPG.mei, with changes since last time in EPG_diff.mei
Slot 1: Font Manager 1.0d : Manage TAP Fonts
Slot 2: Extend v1.7 : Uses the Accurate Recording info to extend recordings (safely)
Slot 3: SecCache (UK) v0.4 : Optimal (UK) section caching to reduce the load on the Toppy
Slot 4: EIT Sub (Game) v0.6 : Provides faster, simpler and more robust EIT data collection, except when playing games
Slot 5: MHEG On/Off A3 : MHEG control
Slot 6: MyInfo B5.6 : Displays & records Toppy basic info
Slot 7: PcControl X27a : Toppy control from PC
Slot 8: MyStuff 6.4 : UI Replacement
Slots 9 - 15 not used


Installed patch list:- Ab Bf Bq Ce Ck Cp Cw Cy De Ec Ee Ef Ep Er Es F Fm Gm H He Kt Mh Nf Ot P Pc R Ra Re Rh Rp Rs S Sd Sl Sr St T2 Td Te Tf Tp Ts Vr Xp Xw Xl
Firmware MS6 Recommended F/W 12/9/2009 modified thus:
Patch Decode Link - Will explain your patches:
http://www.toppy.org.uk/~simonc/dp.html?p=AbBfBqCeCkCpCwCyDeEcEeEfEpErEsFFmGmHHeKtMhNfOtPPcRRaReRhRpRsSSdSlSrStT2TdTeTfTpTsVrXpXwXl

Time Mode set to Auto
Time Offset set to Auto

Found 37 TV channels and 0 Radio channels
No channel problems detected
LCNs of programme channels found on Tx Ch 22 are: 11, 19, 20, 29, 37, 46, 62, 82,
LCNs of programme channels found on Tx Ch 23 are: 1, 2, 7, 9, 80, 301,
LCNs of programme channels found on Tx Ch 25 are: 10, 16, 23, 27, 30, 31, 38, 44,
LCNs of programme channels found on Tx Ch 26 are: 3, 4, 5, 6, 13, 14, 28, 33,
LCNs of programme channels found on Tx Ch 28 are: 12, 15, 18, 21, 22, 24, 47,

Interactive Off
Timeshift On

Memory - Free: 15 MB, Available: 13 MB
Disk - Total: 233 GB, Free: 103 GB

112 recordings (126 GB) + 0 deleted (0 GB) in 14 folders (+ 6 empty folders)

Time since boot: 0:0:1 (d:h:m)

Suggested signature for Toppy forum - copy following lines to signature block at http://forum.toppy.org.uk/forum/profile.php?mode=editprofile
TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4;
Sig generated by MyInfo on 19/7/12

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message
juwlz
Posted: Thu Jul 19, 2012 10:23 am Reply with quote
MyStuff Team Joined: 12 Aug 2005 Posts: 10353 Location: Wokingham, Berkshire (Hannington transmitter)
lyppy wrote:
Found 37 TV channels and 0 Radio channels

Interactive Off

Memory - Free: 15 MB, Available: 13 MB
Not memory then, unless it changes radically when you put subtitles on Wink.

Julie

_________________
5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+BmC0CfCtFsIMPePsR3UUuUxZ
5810, TS On, F/W: F/W: MS6 Recommended F/W 12/9/2009 +BmCfCtFsR3Z
MyStuff info; Help!; Reference
Harmony 885 remote. Sig date 8 April 2012
View user's profile Send private message Visit poster's website
lyppy
Posted: Mon Aug 06, 2012 7:19 pm Reply with quote
Frequent contributor Joined: 10 May 2009 Posts: 123
Me again! Not sure if this is related -
went on hols for 2 weeks. When I came home the MENU sign was on the display so I did the usual to get my channels back. Some of my programs I had kept (recorded fine before my holiday) had been moved into BAD FILES and the spelling of some - for example Most Haunted were spelt MOST8HOAUNTED or similar. What programs it did record didnt work - kept freezing so I deleted all my programs. Today the Toppy has recorded a couple of programs and watching them back the screen has lots of "interference" like lines and squares across the screen as if there is a problem with the arial which there isnt as the other box is working fine. I am guessing my Toppy is on its last legs but any ideas would be great. Thank you

_________________
I AM TECHNICALLY CHALLENGED!

[size=10]TF5800t, TS On, F/W: MS6 Recommended F/W 12/9/2009
TAPs: EPG2MEI v0.96; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6; MHEG On/Off A3; MyInfo B5.6; PcControl X27a; MyStuff 6.4
View user's profile Send private message

Display posts from previous:  

All times are GMT
Page 2 of 3
Goto page Previous  1, 2, 3  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum