Click here to go to the forum index Click here for the home page
 
Author Message

<  Firmwares, enhancements and upgrades  ~  5800 won't start

Page 1 of 2
Goto page 1, 2  Next
apotter
Posted: Sat Feb 05, 2011 6:34 pm Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
Last week I tried re-installing the recommended MyStuff firmware using the FirmwareInstaller.
On reboot of the toppy the firmware apparently applied itself.
Then on the next restart the toppy entererd a 'Load' -> 'C4.56' continuous cycle.

I've checked all the voltages and they all seem to be within tolerance:
5->5
12->12.2
30->30.1
22->24.3
17->16.8
8->7.5
5->5
3.3->3.3
15->15.3

I've also tried with the disk disconnected but get the same behaviour.
(The disk checks out fine when connected to a PC and running TopfHDRW).

Any suggestions as to what to try next?

cheers
Andy
View user's profile Send private message
andyfras
Posted: Sat Feb 05, 2011 6:39 pm Reply with quote
Frequent contributor Joined: 25 Jul 2005 Posts: 3060 Location: Fleet, Hampshire (Hannington)
Voltages look OK.

Try measuring the tab on U20 on the mainboard about 1cm to the right of the main processor, slightly under the left side of the card reader. There should be a steady 1.5V on the wide tab at the top of it. Be careful not to short it to the card reader.

_________________
Toppy PSU repair service or capacitor kits for DIY available - PM me for details.
MyStuff 6.5 : Little Clock : MHEGOnOff : Extend : EPG2MEI : SecCache : EIT_Sub : TSSaver
Channel Organiser : Tap Commander : USB Accelerator : HDD Info : PCControl : Signal Monitor : MyInfo
URC-7555 remote: TF5800 1TB with fan, Recommended_5800.tfd + CfPePsScWfZ
View user's profile Send private message Visit poster's website
apotter
Posted: Sat Feb 05, 2011 6:45 pm Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
Thanks for the quick response!

The U20 tab voltage is a steady 1.5v.
View user's profile Send private message
Geoff Bacon
Posted: Sat Feb 05, 2011 6:46 pm Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3019 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
Did you try pressing 0 as the toppy boots ? - this prevents the Auto Start taps running.

If this works, you have a software problem rather than hardware.
Suggest you
1) either, rename \ProgramFiles\Auto Start\MyStuff.tap to .pat (using TopManager or Altair) or use the native menus to relocate the tap file into \ProgramFiles.
2) Then reboot and leave for 30-40 mins for the EPG to repopulate.
3) After 30-40 mins, reinstate the MyStuff.tap and reboot

Prior to renaming or deleting any files, please save a copy of the current \ProgramFiles\EPG.mei file in case that is what is causing the problem. This can be saved by copying the single file with Altair or by using the "Take Snapshot" option in TopManager (this saves all the files in \ProgramFiles...). Note: the snapshot in TopManager will give you something to fall back on at a later date.

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website
Geoff Bacon
Posted: Sat Feb 05, 2011 6:48 pm Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3019 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
Just noticed that you said that this also happened without the disk.
If this is still the case then my previous post is not relevent as it would appear to be a hardware issue.

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website
alan_m
Posted: Sat Feb 05, 2011 7:43 pm Reply with quote
Frequent contributor Joined: 17 Oct 2006 Posts: 3170 Location: Southchurch Village, Southend-on-Sea
apotter wrote:

Any suggestions as to what to try next?


A factory reset (factory settings), which will require a scan for channels afterwards

You didn't say which firmware was on your box prior to installing the recommended firmware for Mystuff. If going between a Freeview+ (the buggy Topfield firmware with series linking) and a Freeview firmware, or visa versa, you need to do a factory reset as the two firmwares use the memory in different ways.

If you cannot get to the menu to do a factory reset you will have to install Emptysettings using TFDN-USB - a utility that comes with the Topfield Tools for windows. Emptysettings is available from TapWorld http://www.tapworld.net/index.php?option=com_content&task=view&id=483

Other links
Topfield Tools for Windows - http://www.toppy.org.uk/downloads/windows.php
[Edit 29 Jul 2011] Topfield tools for windows no longer available from the above link - try instead the TopfieldTools.exe from
http://www.turbosatdownloads.com/index.php?option=com_rokdownloads&view=folder&Itemid=11&id=2080:software


Using TFDN-USB (towards the bottom of#) http://www.toppy.org.uk/downloads/firmware.php


Last edited by alan_m on Fri Jul 29, 2011 9:40 pm; edited 1 time in total

_________________
www.tap-room.com for TaP news, Jul/Aug 2014 edition now out
5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
apotter
Posted: Sat Feb 05, 2011 8:18 pm Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
Thanks for the suggestions...

Geoff: Yep, this definitely happens with a disconnected disk so pressing 0 has no effect.

alan_m: The toppy isn't started long enough to enable any form of USB transfer.
When power is switched on to the toppy the front panel displays 'C4.56' for about 1 second, the 'Load' for about 3 seconds, then back to 'C4.56' for a second, then 'Load' for 3 seconds and so on.
View user's profile Send private message
alan_m
Posted: Sat Feb 05, 2011 8:30 pm Reply with quote
Frequent contributor Joined: 17 Oct 2006 Posts: 3170 Location: Southchurch Village, Southend-on-Sea
apotter wrote:

alan_m: The toppy isn't started long enough to enable any form of USB transfer.


TFDN_USB doesn't work in the way you think. The installer you used previously required the box to be fully up and working - TFDN_USB doesn't. In fact it is the documented way of getting out of the C4XX - run - reboot cycle when the problem is a software/firmware corruption.

Read carefully the description of the firmware load process using TFDN_USB in the link in the previous post.

The detection of the USB link to your PC using TFDN_USB is in the very early stage in the boot process. TFDN_USB can be used to load firmware when you think you have fully "bricked" your Toppy. The Emptysetting file just pretends to be firmware that is required to be loaded in "the old fashioned" way and will perform a reset on your box. Using TFDN_USB and Emtysetting should take around two seconds from pressing the front panel power button to load finished. You will then have to again scan for channels.

_________________
www.tap-room.com for TaP news, Jul/Aug 2014 edition now out
5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
apotter
Posted: Sat Feb 05, 2011 8:52 pm Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
Ah, ok, tried that...
With toppy switched off (at the wall), I connect the USB cable, then start TFDN_USB, 'find' the EmptySettings.tfd and click download.
Then I turn on the toppy (at the wall) it goes straight to the C4.56, then Load.
The TFDN_USB transfers the EmptySettings firmware and reports 'End'.
At this point I disconnect the USB, switch off the toppy and then switch it back on.
But, still in the C4.56/Load cycle Sad
View user's profile Send private message
apotter
Posted: Sat Feb 05, 2011 11:14 pm Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
Solved!
Whilst the EmptySettings.tfd didn't seem to have any effect, I decided to give TFDN_USB a go with the recommended firmware downloaded from Toppy.org.
It ran through the firmware transfer and installation fine.
With some trepidation I restarted my toppy. But no need to worry...it booted into the standard Menu. So, reset factory settings (for good measure), restarted again and scanned for channels.
MyStuff started with previous settings and everything seems in order again.
Very Happy Very Happy

I guess this was down to corrupted firmware somehow?

Thanks again to alan_m for highlighting the way TFDN_USB works - and to everyone else for the help.

Andy
View user's profile Send private message
alan_m
Posted: Sat Feb 05, 2011 11:42 pm Reply with quote
Frequent contributor Joined: 17 Oct 2006 Posts: 3170 Location: Southchurch Village, Southend-on-Sea
Now check your MyInfo log file to see if you have the De and Re patches installed in your firmware (recommended if using Mystuff). They can be added without reinstalling firmware if missing.

http://forum.toppy.org.uk/forum/viewtopic.php?p=224068#224068

[edit] An alternative TAP for adding patches to existing firmware is HDFW - available from Tapworld[/edit]

De and Re patches from
http://www.toppy.org.uk/~r2-d2/patches.html


Last edited by alan_m on Sun Feb 06, 2011 12:17 am; edited 1 time in total

_________________
www.tap-room.com for TaP news, Jul/Aug 2014 edition now out
5800 - 1Tbyte HD and fan F/W: MS6, 5.13.65T 18 Nov 2010 -Te+B2D plus aXeL
Auto Start:MyStuff 6.5|EPG2MEI v0.96|Extend v1.7|SecCache (UK) v0.4|TF5000 Display v1.53|MHEG On/Off A3
View user's profile Send private message Visit poster's website
Geoff Bacon
Posted: Sat Feb 05, 2011 11:49 pm Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3019 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
Try my TopManager program (link in signature).
Use "Display|MyInfo Log" and cust and paste into this thread (it shows your configuration).
Then, set up a signature by using "Tools!Update Forum Profile" (after the display).

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website
apotter
Posted: Sun Feb 06, 2011 12:33 am Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
I re-installed the recommended MS firmware, which I understand includes both De and Re, using the ToppyFirmwareLoader.
The MyInfo log is now this:

Code:
MyInfo B5.5 Logging settings etc on: 6/2/2011 at 00:18

Waiting for other TAPs to load and settle

Ini file found
Starting to record data 336 seconds from boot

System ID: 456
TV Output: Type = Auto, Video = RGB, RF Channel = 36
Reported firmware version: TF-NPT 5.13.65T dated Oct 10 2009
Base firmware version: 5.13.65

Running TAPS:
   Slot 0: EPG2MEI v0.96  :  Dumps the EPG data to disk as EPG.mei, with changes since last time in EPG_diff.mei
   Slot 1: MyStuff 6.3  :  UI Replacement
   Slot 2: MyInfo B5.5  :  Displays & records Toppy basic info
   Slot 3: Font Manager 1.0d  :  Manage TAP Fonts
   Slot 4: Extend v1.7  :  Uses the Accurate Recording info to extend recordings (safely)
   Slot 5: SecCache (UK) v0.4  :  Optimal (UK) section caching to reduce the load on the Toppy
   Slot 6: EIT Sub (Game) v0.6  :  Provides faster, simpler and more robust EIT data collection, except when playing games
   Slots 7 - 15 not used

Installed patch list:-  Ab Bf Bq Ce Ck Cp Cw Cy De Ec Ee Ef Ep Er Es F Fm Gm H He Kt Mh Nf Ot P Pc R Ra Re Rh Rp Rs S Sd Sl Sr St T2 Td Te Tf Tp Ts Vr Xp Xw Xl
Firmware MS6 Recommended F/W 12/9/2009  modified thus: -Sy
Patch Decode Links - Will explain your patches:
   MS6 Recommended F/W 12/9/2009 :- http://www.toppy.org.uk/~simonc/dp.html?p=AbBfBqCeCkCpCwCyDeEcEeEfEpErEsFFmGmHHeKtMhNfOtPPcRRaReRhRpRsSSdSlSrStT2TdTeTfTpTsVrXpXwXl
   Missing patches:- http://www.toppy.org.uk/~simonc/dp.html?p=Sy

Time Mode set to Auto
Time Offset set to Auto

Found 59 TV channels and 24 Radio channels
No channel problems detected
LCNs of programme channels found on Tx Ch 54 are: 3, 4, 5, 6, 13, 14, 28, 33, 102, 103,
LCNs of programme channels found on Tx Ch 56 are: 11, 19, 25, 29, 44, 82, 84, 87, 95, 97, 190, 306, 723, 725,
LCNs of programme channels found on Tx Ch 61 are: 1, 2, 7, 9, 70, 71, 80, 81, 105, 301, 700, 701, 702, 703, 704, 705, 706, 707, 708, 709, 710,
LCNs of programme channels found on Tx Ch 62 are: 10, 27, 30, 31, 72, 92, 93, 101, 104, 109, 189, 191, 192, 307, 308, 309, 724, 727, 728,
LCNs of programme channels found on Tx Ch 67 are: 12, 15, 18, 24, 85, 89, 90, 94, 96, 99, 199, 711, 712, 713, 714, 715, 716, 718, 722,

Interactive On
Timeshift On

Memory - Free: 13 MB,  Available: 12 MB
Disk - Total: 232 GB, Free: 185 GB

Checking for actual or imminent recording           
Found apparently invalid file:- /DataFiles/Holby City.rec
Checking for actual or imminent recording           
Found apparently invalid file:- /DataFiles/Harry Potter Order of the Phoenix.rec
35 recordings (48 GB) + 0 deleted (0 GB) in 5 folders (+ 0 empty folders)

Time since boot: 0:0:5 (d:h:m)

Suggested signature for Toppy forum - copy following lines to signature block at http://forum.toppy.org.uk/forum/profile.php?mode=editprofile
[size=10][b]TF5800[/b], IA On, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy
 [b]TAPs:[/b] EPG2MEI v0.96; MyStuff 6.3; MyInfo B5.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6;
Sig generated by [url=http://myweb.tiscali.co.uk/emjbtaps/MyInfo/MyInfo.zip]MyInfo[/url] on 6/2/11[/size]
View user's profile Send private message
apotter
Posted: Sun Feb 06, 2011 12:38 am Reply with quote
Joined: 24 Jun 2007 Posts: 9 Location: Swindon
...and have also update my signature Smile

_________________
TF5800, TS On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvFsIPeR5UUuVbWf
TAPs: EPG2MEI v0.96; MyStuff 6.3; MyInfo B5.5; Font Manager 1.0d; Extend v1.7; SecCache (UK) v0.4; EIT Sub (Game) v0.6;
Sig generated by MyInfo on 6/2/11
View user's profile Send private message
Geoff Bacon
Posted: Sun Feb 06, 2011 11:09 am Reply with quote
Frequent contributor Joined: 11 Jan 2007 Posts: 3019 Location: Bristol ŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻŻ Windows XP, USB
@apotter

Your MyInfo log and signature look fine.

You could possibly reduce some of your TV channels to 35-40 say by removing things you are not interested in; this would improve memory usage and reduce the load collecting EPG information. Channels are best removed with the Channel Organiser tap (it also adjusts other files to refect the channel lineup)

Suggest you use TM "Tools|Check MyStuff"; this checks that you don't have any rogue entries in your favourites files (amongst other things)

Once you have got it working to your satisfaction, take another snapshot as a backup.

Geoff

_________________
TopManager program
TF5800, IA On, F/W: MS6 Recommended F/W 12/9/2009 -Sy+EvEzHsPfUUuZ
TAPs: PcControl B1.4; StopExit v1.01; QuickJump 1.72; MyInfo B5.6; Font Manager 1.0d; EPG2MEI v0.96; CrashTrace v0.4; EIT Sub (Game) v0.6; Extend v1.7; WSSkiller V2.12d; SecCache (UK) v0.4; MyStuff 6.5;
Sig generated by MyInfo on 6/9/13
™
View user's profile Send private message Visit poster's website

Display posts from previous:  

All times are GMT
Page 1 of 2
Goto page 1, 2  Next

Jump to:  

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum